3

Previously in 10.6.8, I was able to start Google using open /Applications/Chrome.app --args --kiosk http://www.google.com

Now, on newer systems, that does not work anymore correctly. The only way to get rid of the address bar seams to be using of the presentation mode. Does anyone know the switch to call that mode?

I use the shell script for a presentation computer to start the browser on startup automatically in fullscreen mode.

Any help is appreciated.

3

I tested this out and then it wouldn't let me exit kiosk mode. I had to Cmd+Q to get out of Google Chrome. Save the following to a script, something like ChromeKiosk.sh and chmod +x ChromeKiosk.sh to get it to run.

#!/bin/bash
open "/Applications/Google Chrome.app" --args --kiosk http://www.google.com.au

This will open Google Chrome to the http://www.google.com.au webpage. Change it as you need. Copy and paste the rest of the script

If you want to turn it into an AppleScript so that you can create an application that can in turn be automatically run each time the computer reboots to a default specified user, use the following code and when you save the script, change it's type to Application

do shell script "/bin/bash open \"/Applications/Google Chrome.app\" --args --kiosk"

It's requires the \ (escape sequence) before the " because of the way the shell reads the spacing between the words Google and Chrome in the filename. You can also write it as

do shell script "/bin/bash open /Applications/Google\\ Chrome.app --args --kiosk"

It's just that I've never favoured the look of seeing a escape before a backslash. It's too messy. Stick with either the BashScript option at the top or use the 1st of 2 AppleScript lines and save it as an Application type.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .