2

I have a MacBook Pro 17" early 2009 running Snow Leopard, I've recently upgraded Windows 7 running on the bootcamp partition to Windows 8.

All works fine apart from the trackpad.

Bootcamp 3.1 is installed, I've tried upgrading to 3.2 but I get an error message saying "Boot Camp requires that your computer is running Windows 7.". I've tried running the install in compatibility mode but no luck.

I've tried uninstalling the touchpad from the device manager and reinstalling from the Bootcamp drivers folder but it still has "This device is not configured correctly. (Code 1)" as the device status.

Anyone got any ideas? I'm willing to upgrade Snow Leopard if it's certain to fix this issue.

  • does the trackpad work at least for your mac operating system? If not you could try turning off bluetooth and seeing if that works to free up the touchpad – boulder_ruby Dec 13 '14 at 21:28
  • Thanks for the comment but it was a long time now and have given up running win 8 on MBP. – WooHoo Dec 16 '14 at 11:45
1

I think your MBP will handle Bootcamp v4 - you could try installing it from Windows, it runs as Bootcamp Services, and may alleviate some of your problems. I have done a similar thing on my 2009 13" MBP - all works fine apart from tapping (not clicking) the touchpad. Two finger scroll works but not tap-clicks. All very frustrating.

  • Thanks for the reply Sarx, but I have new machine and gave up running win 8 on the MBP. – WooHoo Jun 18 '14 at 7:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .