The Lapzilla of my stable has given up the video ghost. Everything else works, save for the fact that when booting it either ends up on a white screen, or a blurry black & white checkerboard. I can ssh to it and do most anything you can do from Terminal sessions, I can even go into single user mode, if the screen does not misbehave completely. It is running Lion.

I have done all the things you can think of, change hard drive, tried with external monitors, reinstall from scratch to Leopard, Snow Leopard and Lion, do the NVRAM dance, etc. So apart from the video, it works, and I am not going to go for a new logic board, not worth the hassle and the expense.

I am planning to use is as "test server" for when I want to play around with Nginx and PHP, that sort of thing. My fear is that if I change something and it doesn't boot or hangs in the process and I cannot ssh to it, I will have no way to troubleshoot and the machine will be in a sort of vegetative state,

Is there a way to get a terminal session, say with a screen connected via USB or something, so that even if do not get the bells and whistles of the Finder, which I do not need, I can still see what's happening without having to rely exclusively on SSH via Wi-Fi?


Can you boot into Target Disk mode, connect the computer to the network, and use the drive/system remotely..

There are other startup possibilities , and there is also Apple Remote Desktop, and Screen Sharing. Have you tried connecting an external monitor? The screen must be connected through the video port - is that what has blown? Hope this helps a bit

  • Target disk mode (which I have not tried) would only leave the machine as an external disk to the one it is connected, not really what I am looking for. Tried with external monitor, to no effect. Screen sharing does not work. Again, with this and the other solutions you suggest (like ADR), I would be left relying on a non-physical connection to the machine, which is what I am trying to avoid. I know video is dead, and I am not trying to fix it. Thanks for the effort – cucu8 Dec 8 '12 at 11:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .