I have been attempting to resolve an issue with AirPlay from an iPad to AppleTV. Here are the details:

Playing media (audio or video) originating on the iPad sent to AppleTV via AirPlay does not work.

  • With audio-only media, the result is mostly silence with occasional very short bursts (less than 100ms) of sound.

  • With video, the video does not play at all. The TV display can be one of

    • black screen with a rotating spinner in the center

    • black screen with the blue time bar at the bottom and a rotating spinner at the bottom left

    • white screen with the blue time bar at the bottom and a rotating spinner at the bottom left

The failure mode is extremely specific, and requires:

  1. The media being played resides physically on the iPad. Media of any type being streamed from the Internet via the iPad does not have this problem.

  2. The problem occurs only when both the iPad and AppleTV are on the same 5GHz network. Any other combination with either the iPad or AppleTV or both on the 2.4GHz network operates correctly.


iPad mdl:MC979LL iOS:5.1.1 AppleTV mdl:MD199LL/A OS:5.1.1(5433) Router Netgear WNDR3400V2 with firmware V1.0.0.34_1.0.52

The router is running in access-point mode where it does not do any routing, just provides wireless access.

During testing I tried the following:

  1. Changing WiFi channels

  2. Upgrading the router firmware to the latest version

  3. Rebooting and power-cycling all equipment multiple times, including hard-resetting the iPad

  4. Testing with iTunes on the PC not running, in case it is somehow saturating the connection to the AppleTV

  5. "Reset Network Settings" on the iPad.

So far no luck.

BTW, I wanted to tag this post 802.11n but that tag does not exist and I can't create it with less than 300 rep. Would somebody please create that tag, add it here and delete this paragraph? Thx.

2 Answers 2


I was poking around in the router's admin interface and examined the wireless settings. On this particular router, for each frequency band (2.4GHz and 5GHz) there is a "Wireless Mode" setting that enables high-speed operation. It has three settings for the 5GHz network:

Up to 54Mbps
Up to 145Mbps
Up to 300Mbps

The factory default is Up to 300Mbps. I tested all three settings, and the only one that works is the slowest Up to 54Mbps.

It appears that AppleTV's 802.11n implementation does not support speeds above 54Mbps.

  • If it claims 802.11n then it supports higher frequencies, but perhaps you have interference, or some other RF issue. Devices will normally try to use the fastest speed possible, by forcing a slower speed, you have basically made the everything stop trying for a faster speed, and to settle on a lower speed. WIFI is a serious PITA to troubleshoot correctly. You need specialized RF equipment to do it properly.
    – Zoredache
    Dec 7, 2012 at 20:42
  • I find it curious that it fails only when both devices are on 5GHz. If either one is at 2.4Ghz there's no problem. Could it be a bug in how the iPad and AppleTV handle collisions at 5GHz? Dec 8, 2012 at 4:04
  • Adjusting my settings in my wireless router to 54Mbps did the trick. Now my airplay works great with no issues!
    – user44172
    Mar 2, 2013 at 18:49
  • The Netgear might have pre-n and not the final version. Mar 2, 2013 at 21:51
  • 54mps tweak seems to have worked for me, thanks for sorting this annoying problem!
    – user85838
    Jul 24, 2014 at 16:46

I eperienced this problem as well -- AirPlay icon did not even show up on my iPad.

The solution for me was to go into my Netgear's wireless (N) router settings and UNcheck the "Enble wireless isolation" box of both the 2.4 Ghz and 5.0 GHz bands.

The AirPlay icon appeared almost instantly.

Happy trails to all of you!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .