Is it possible to turn off the new invite badge and the list of new invitations within the Calendar application on the iPhone?

My boss has his assistant review his invitations and accept/deny them for him, so he has no need to do this from his phone. He therefore doesn't want to see the red badge on the Calendar app icon on the home screen, or the red badge in the bottom right hand corner of the screen within the Calendar application that says he has six new invitations, and he doesn't want to see the list of new invitations upon clicking that button.

I've recreated this on my iPhone and have screenshots available as an example (however because I'm a first time poster it won't allow me to post them). Any help someone could provide would be appreciated.

  • For iOS ≥10 see the answer below from @twerth5000: Settings → Notifications → Calendar
    – iolsmit
    Aug 13 '19 at 9:21

Actually, this functionality has been moved into the Notification settings for Calendar items (Settings > Notifications > Calendar).

In that view you'll have the option to change notifications for: Upcoming Events; Invitations; Invitee Responses; and Shared Calendar Changes. Each one give the ability to select: whether its shown in notification center; notification sound; badge app icon; show on lock screen; and the alert style!


There are two things that you can do here.

  1. Open Settings > Mail, Contacts, Calendars > Scroll down to the Calendars section (near the bottom), and change "New Invitation Alerts" to Off.
  2. In the Settings app, tap Notifications > select Calendars, and then turn off Calendars notifications in Notification Center (if desired), and set the Alert style to "None", and, most importantly, turn "Badge App Icon" to Off.

Unfortunately, to the best of my knowledge, there is no way to specifically disable the Red badge that is inside the app. However, it is possible turning off "New Invitation Alerts" will have that effect.

  • Thank you so much for this! I work night shift at a datacenter, so when everyone is inviting me to meetings in the morning, it is waking me me constantly. I can't exactly use the "Do not Disturb" feature for this since I am on call at some points, but the "do not disturb" is usually what helps with this, except when I am on call...
    – David
    May 23 '13 at 21:11

Most of the replies so far are outdated, but there are probably some like me still interested in this.

As of iOS 10, this is easy. Open Settings>Notifications>Calendar. From here you can disable certain alerts, including only those for Invites.


I just tested answering the invites with my phone in Airplane mode. It appears to remove the invite badge without sending a notification to the source.

Personally Apple should have a Dismiss option, but this method might just do the trick until they provide that option.


Instantly clear notifications in calendar inbox, never get those again:

Calendar > calendars Next to each calendar (shared/subscribed) is an “info” button. Click.

Shared Changes: turn off. This will instantly clear the inbox.

FYI: Below the color choices is Event Alerts: choose on/off to get notification for the upcoming events (day before, hour before, time to leave, etc), whatever alert option was initially used when event was created.


Settings > Notifications > Calendar: You can specify what to receive.
Here is a pic of the choices: enter image description here


I've had this same issue and unfortunately there is no way to turn off the invitation count one sees on the bottom right of the calendar app. I've shut off all notifications (badges, banners, etc) for calendar and these still show up, at least until the invite is attended to in the email inbox. So if one's admin is completing invites, the counter should in theory update in the calendar app in the bottom right corner.

My situation is a bit unique in that my personal account is part of a family domain hosted on outlook.com (no longer offered for new signups at Microsoft) and I receive counters for invites to other "shared" calendars that aren't even mine (belong to spouse, child, etc). I think these calendars are being seen by the device as "other" calendars of mine, when in fact they are not mine. If I click "accept" it just reappears right back in that list of notifications in calendar. I've determined that because I don't have edit rights to those other family members' calendars, the server just rejects my "acceptances" and resends the invite. Endless cycle. Very annoying. Invitations to calendars shared with me should not result in those other individuals' calendar invites coming to me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .