Forgive the long story, but I have a mix of old knowledge and unfamiliarity with Mac so I don't know what might be relevant. The tldr version is my iMac won't boot.

Trying to put op an upnp server: Windows Server on my Leopard Imac I found afterwards that the service planted itself. Trying to quit the process, immediately triggered a sort of reboot screen, and the OS responded, but still the service was not quitted.

I tried (I'm a former Win user, and not acquianted with unix - I picked up the command from a forum) with a sudo launchcntl -w to disable the service. By doing this, the mac spinning wheel appeared and nothing responded anymore.

I powered down the Imac. When trying to restart the boot reached the gray apple logo screen with the spinning wheel still there, as if it was still trying to disable WindowsServer. The keyboard locked immediately and caps light on.

Tried SMC reset, pram reset. As the keyboard was locked each time I tried, no luck. Now, the power button only responds when I first detach the power chord, and reattach it. Inserting the 1st install disk trying to boot from it and run diagnostics didn't work. Always the same screen with the spinning wheel, no keyboard response. DVD is even locked, and cannot eject it anymore.

Safe boot of course doesn't work as not one keyboard is accepted.

So, I'm dead locked on all sides. Must admit that windows still gave you a chance to boot. This mac is dead on a service disablement process. The damn keyboard locks, so I have no control. I whished there was a reset button like on the TC.

What to do ? I have no idea. Backup is not available on Time Machine.

Does this need hardware repair or does someone have any ideas.


This is a bit of a mess - but you could do one test to isolate the hardware from the software (and some of the hardware).

Power off the Mac and pull the power cord. Disconnect everything you can - keyboard, mouse, etc... Take out all RAM - the manuals are at http://support.apple.com/manuals if you are not familiar with the safety precautions and tools needed.

Then plug in only the power cord and wait a few seconds. If the Mac doesn't start up, press the power button once.

  • You should get three beeps if the machine is healthy.
  • Power it off and put the RAM back in - be sure it's seated well / pushed in completely.
  • Connect only the mouse and power it on holding the mouse button down (button one if there are several).
  • The CD should come out if the hardware is healthy.
  • Shut it down (you can use the mouse or connect a keyboard if needed).
  • Now power on with the shift key held.

At this point, if your Mac booted, it's likely everything is fine and you can use Apple's support to troubleshoot the startup issue. If anything doesn't go like I mentioned - you should take a printout of this and what your results were and post here, or seek hardware help.

  • I managed to get the dvd install disk 1 out in the mean time with a tip from another forum. Holding left button mouse and push eject. It worked.But I gues this will not get me further . I expected an answer without having to pull out hardware. But I understand. I see no screws on the back. But I can have a look. – user35835 Dec 2 '12 at 18:51
  • Feel free to skip the RAM pulling and assume it passes. If that step fails - you won't get past others either. Maybe I should make an edit to the answer... – bmike Dec 2 '12 at 18:54
  • I'm dutch speaking, so I don't follow you. The manuals link does not include the Imac. I disabled beeps, because I didn't like the start up sounds all the time. Sorry. – user35835 Dec 2 '12 at 18:56
  • I can only power on when first detaching the chord, placing it back, and the I can power on. Followed your steps. No result. – user35835 Dec 2 '12 at 19:06
  • Managed to pull out the ram, and followed your steps. But at boot I heard more than 3 beeps, it repeated beeping. I shut down. Same problem. It's worse I guess ? No ? – user35835 Dec 3 '12 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .