When I start the mini player in iTunes 11 on Mountain Lion, I do not see the expected track information which, when moused over, is supposed to change to playback controls:

enter image description here

Instead, the playback controls are permanently displayed and I can't find a way to show track info (aside from album artwork). Also, as shown in the screenshot below, whenever the mini player is the active window, the rewind button has a blue highlight.

enter image description here

The reviews that have appeared on the web, and Apple's keynote, suggest that this is not normal behaviour. Is it a bug that others are experiencing and is there a way of fixing it, apart from waiting for an update?

  • I'm sorry to sound stupid but I have no clue what your instructions mean? What exactly does "press tab until the focus ring moves to the Up Next or Search icons" mean? What is 'tab'? Also I don't know if this is related but my rewind button is always highlighted, I had the same issue with iTunes 10. Thanks in advance. – user35782 Dec 1 '12 at 19:16
  • 1
    @Steve: by Tab they mean the Tab key on your keyboard. It's to the left, the third key from the top, which looks like this: ->| It's even faster to just press shift + tab together once. (Shift is the big hollow arrow pointing upwards.) Posted as an answer because I don't have enough "reputation" to reply to a comment. – Alex Wally Dec 3 '12 at 10:39

The answer is in the comments on this TUAW post. The keyboard focus on the mini player (indicated by the blue focus ring) is on one of the playback controls, which prevents them from hiding. Click the mini player background to bring it to the foreground, then press tab until the focus ring moves to the Up Next or Search icons, and track information will appear whenever the mouse is not over it.

| improve this answer | |
  • 2
    This works! Apparently, this issue happens only for people who have chosen to use tab to browse through all controls in the keyboard preferences. – duci9y Nov 30 '12 at 17:30

Tabbing to the search or "up next" solves the track name visibility problem, but then it stops pressing space bar to play-pause.

| improve this answer | |
  • That is definitely a bug in iTunes 11. This workaround works though. Interestingly enough, this only happens if you have "Full Keyboard Access" enabled for "All Controls" in the Keyboard/Keyboard Shortcuts System Preference. – daviewales Dec 5 '12 at 22:18

I've rewritten the old iTunes 10 MiniPlayer open-source. This should keep working with new versions of iTunes!


| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .