Ok, unless I'm missing something, I can't see my podcasts anymore? The only place they appear is in a new "Podcasts" playlist, which isn't much use to me for keeping track of episodes and subscriptions.

Am I just being blind? :-/


You may need to recheck the Podcasts checkbox in the menu iTunes | Preferences... | General tab. OSX Daily suggests that it may be unchecked by default. Once checked, podcasts should appear under Library rather than as a playlist.

| improve this answer | |
  • It seems, even though there are episodes in a playlist, that I have to add every single episode from scratch since I upgraded :( – Django Reinhardt Nov 29 '12 at 22:19

If you hit option-command-s it will bring up the sidebar. You will see your Podcasts there.

| improve this answer | |

Once you have podcasts showing, using the dropdown upper right, if you switch to list view (weirdly located as one of 3 options in center of entire window, under "progress bar"), if you then click the twirl-down arrow for a podcast, a big gray arrow will automatically show if there are un-dowloaded episodes of that podcast. Click that, and a window will ask you if you want to download all episodes, which obviously you do. It all seems a little odd and seems like Apple needs to work on tis a bit more.

| improve this answer | |
  • Question is how to get the podcasts showing – mmmmmm Jan 1 '13 at 12:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .