I'm looking for some one who may have configure the Asix AX88179 to work with OSX 10.8 Mountain Lion. This chipset (AX88179) is embedded in most of the very new the USB 3.0 Gigabit Ethernet adapters.

I bought one of them coming from Digitus and after one day on it, it is recognised by Mountain Lion on my Macbook Air, it seems that the network diagnostic tool is OK, but I was never able to connect on my mails and run any browsers (Safari, Firefox etc...). There is something wrong in the network configuration.

I'm using the versions 1.1 and 1.2 of the Asix drivers (dowload from the Asix site and coming from Digitus).

  • I also can't get this to work on Windows 8. I have tried different drivers as well - as soon as I feed it an Ethernet cable the device just turns off and on. Could it be a problem with the chipsets?
    – user37017
    Commented Dec 20, 2012 at 19:50
  • Looks like version 1.3 is out for this device. Try it. asix.com.tw/products.php?op=pItemdetail&PItemID=131;71;112
    – user39593
    Commented Jan 14, 2013 at 17:50
  • 1
    I have the 1.3 driver now, but it only works if reboot and have the adapter already plugged in the usb. A bit annoying to reboot whenever I need gigabit (OSX 10.8.2). Commented Jan 24, 2013 at 19:37
  • I also have this problem with my StarTech USB 3.0 Hub with gigabit ethernet (Part ST3300U3S). It uses the Asix AX88179 chipset. Running the 1.3 Asix Drivers and OSX 10.8.3. Loading the kernel extension (drivers) manually as the answers suggest do load the module, but the device still does not see the ethernet device. Rebooting does not help. Just posting so others might see this issues exists for this StarTech hub as well. Commented May 2, 2013 at 13:35
  • 1
    @MikeOhlsen I had exactly the same problem with the same device. I solved it by installing the latest drivers from Asix (they're on 1.4 even though StarTech is currently only distributing 1.3). You can find them here: asix.com.tw/products.php?op=pItemdetail&PItemID=131;71;112 Commented May 12, 2013 at 22:28

2 Answers 2


This is fixed in Mac OS 10.8.3.

In MacOS 10.8.2 although I faced an issue: I have a version from Delock running driver V1.3.0 (but V1.2.0 showed exact same behaviour). Adapter runs fine on first connect. If unplugged and plugged in again it will not work unless I reboot. Best solution I found is to reload the driver by hand. That saves you at least the reboot.

sudo kextunload -b com.asix.driver.ax88179_178a
sudo kextload -b com.asix.driver.ax88179_178a

If your driver has a slightly different name (for whatever reason) you can look it up with:

kextstat |grep asix
  • The solution of reloading the driver via the terminal works! However, I think the order of the commands should be reversed. (first unload and then load)
    – user46576
    Commented Apr 3, 2013 at 0:09
  • @user46576 Thanks for the comment. If you feel confident that an answer is wrong, just go ahead and edit it. The author gets notified and can review / change it back if needed. This is pretty easy to tell the order is swapped, and should be an edit IMO.
    – bmike
    Commented Apr 7, 2013 at 16:32

If you have the Android File Transfer app installed, try removing it - that made the 1.3 drivers work for me, including disconnecting and reconnecting (through a USB 3.0 hub) without a reboot

  • Removing the Android File Transfer app worked for me on the 1.3 drivers. Thanks
    – user46936
    Commented Apr 7, 2013 at 15:38
  • By uninstall, do you mean just deleting the app from your applications folder? Commented May 9, 2013 at 20:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .