I discovered in Activity Monitor that I have several leftover processes running in the background that shouldn't be there anymore. I deleted these preference panes long ago with an application that was supposed to find all the extraneous files. So how do I get rid of them?

I've tried to kill the processes by quitting, force quitting, terminal commands involving killall/kill, launchctl unload and they still won't go away. They just restart themselves. What's more is I can't find where these reside on my system. They aren't listed in the "Login Items" section under my user account, as they are owned by root. I've searched but found no exact answer to my problem. I've found similar situations but not the same.

Here are the processes in question in my particular case:enter image description here

2 Answers 2


Many preference pane applications also have background processes or kernel extensions. Removing the preference pane doesn't remove them, so you have to run an uninstaller or delete the files separately.

Background processes are often started by launchd services in the LaunchDaemons or LaunchAgents folders. You can remove them by just deleting the property list files (and restarting or logging out and back in). Some applications add login items that can be removed in the Users & Groups preference pane.

The executables for the background processes are often somewhere in the root or user library, but they don't necessarily have to be removed.

Kernel extensions (in /System/Library/Extensions/) can also be removed by just moving them to the trash.

You can use Consultant's Canary to print a list of components that didn't come with OS X.


My solution to this problem ended up being simpler than I realized. While in Activity Monitor, I clicked 'Inspect' on one of the selected processes and discovered it was a sub-process of 'launchd.' That was why I couldn't kill it. After some searching with new information, I found the location of the files in question under /Library/LaunchDaemons. I selected the offending files, trashed them after entering my admin password, restarted and now they are no more. I had previously tried the terminal command launchctl unload to unload the processes but this kept failing no matter what I did, so I resorted to just deleting the files as I didn't need them anymore.

  • 1
    All processes except kernel_task and launchd are subprocesses of launchd. launchctl unload only unloads a service temporarily. launchctl unload -w unloads it permanently, but just deleting the property list also works.
    – Lri
    Nov 28, 2012 at 12:11
  • @LauriRanta - I didn't know about the -w. I will try that next time.
    – montane
    Nov 28, 2012 at 16:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .