I had an iPhone 4 with iOS 5 which I regularly backed up using iTunes. Then I used a Android device for a little over a year. Now I'm back on iOS with an iPhone 5. So I'm trying to setup it with the Restore from iTunes backup option. But I get the following error:

enter image description here

Is there any way to fix this? I would really like to get my pictures and messages restored.

Update: Some more information. I used to have another computer, have not upgraded MacBook -> MacBook Pro, so I copied the ~/Library/Application Suppor/MobileSync/Backup folder to the new computer before the restore process. Restoring on the original MacBook yields the same result.

  • The backup neither contains the iOS version nor is it bound to any specific version. Only user data is backed up and can be restored on any other iOS version, especially upgrading should work without problems. So probably your backup is really corrupted.
    – Koraktor
    Commented Nov 27, 2012 at 22:38
  • @Koraktor tried an older backup as well, the same problem. Sounds strange that it two of my backups should be corrupted.
    – tidbeck
    Commented Nov 27, 2012 at 23:08

2 Answers 2


I have restored plenty of iOS 5 backups onto iOS 6 devices so the problem here is almost certainly that the backup is now (and may have been all along) corrupt.

Before throwing that backup away and restoring the iTunes files from a backup of the computer where it was stored (hopefully you have that), you could try restoring the backup onto another device such as a borrowed iPad or iPod touch (or iPhone) to be sure it's not the phone you are restoring the backup to.

The article iTunes: About iOS backups will help you locate where your computer stored this backup set as well as general info to support the idea that you can back up an older OS onto a newer OS (but not the other way around).

  • Tried different backups and get the same issue with all of them. Sounds strange that all my backups should be corrupted.
    – tidbeck
    Commented Nov 27, 2012 at 23:16
  • Looking at the info.plist of my backup reviled that I was using iTunes 10.5b43. This was because I used my device for development. I did not remember that. So I answered my own question. Thanks for the answer +1.
    – tidbeck
    Commented Nov 27, 2012 at 23:40

Make sure your backup is not from a beta version of iTunes, which may happen if you used your phone for development.

This can be done by looking in the Info.plist file for the backup, which are located in ~/Library/Application Suppor/MobileSync/Backup. The iTunes version is stated in the en of that file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .