With the Notification Center in Mountain Lion, I get an alert when software updates are available. The problem is, my only options are 'Details' and 'Update'. I don't want to interrupt my work to install the update and I don't want to launch the App Store to see what the update it. I just want to dismiss the alert so that it doesn't come back again. I know about the tip that swiping the notification off the side of the screen to make it go away, but it seems to come back a few minutes later.

I've looked in the System Preferences to change it to a 'banner' instead of an 'alert' so that it would go away by itself after a few seconds, but there is no option to control software update notifications. I've also closely read these two related questions and can't seem to make the answers there work for me to suppress repetitive update notifications.

I can turn off software updates all together, but I'm not really against the update notifications -- as long as I can acknowledge it and not have it bother me again.

Is there a hidden configuration option that I can invoke to control these notifications from re-appearing?

  • 1
    Very interesting. I've never considered removing all updates in a fell swoop. This is a nice counterpoint to How to opt out of specific App updates using the App Store model?
    – bmike
    Commented Mar 9, 2013 at 16:48
  • Have you seen this one: How do I turn off App Store notifications in Mountain Lion?
    – Eir Nym
    Commented Mar 9, 2013 at 22:25
  • I'm unable to test this (anybody know how to force an update notification to appear?) but it strikes me that this is exactly the kind of situation where Apple's engineers would make it possible to hold down Option while clicking to slightly change the action to something else — such as permanently dismissing this warning, rather than temporarily doing so. But I suspect the feature you want will be in OS X 10.9 when it comes out. Commented Mar 12, 2013 at 13:52
  • I'd love an option to pause update notifications, especially when traveling, since I don't generally update when away from home (and my backup drive).
    – TomG
    Commented Sep 27, 2013 at 23:48

6 Answers 6


I have just disabled checking for updates automatically from System Preferences:

I install updates manually from App Store or with sudo softwareupdate -ia.

I tried adding this command to the root's crontab (and not restarting after updates):

0 14 * * * /usr/sbin/softwareupdate -ia

I didn't have any issues at first, but after the 10.8.3 update, Safari started crashing on launch until I restarted. After that I changed -ia to -da so the command just downloads updates. softwareupdate does not include updates for App Store applications though.

  • Brilliant - just install everything and you won't be bugged that an update is pending.
    – bmike
    Commented Mar 13, 2013 at 17:45

There is a SQLite database located at ~/Library/Application Support/NotificationCenter that looks to house all the information for registered Apps in Notification Center.

The Mac App Store does have some entries in the DB, but I don't see anything that would allow you to change the settings. Perhaps someone with more knowledge could poke around and find out more.

enter image description here


ckoerner was on the right path. This is a bit technical, but I've been blessedly free from the 10.8.3 update notice all day.

  1. Go to ~/Library/Application Support/NotificationCenter

  2. Figure out which .db file is the newest.

  3. Open that file in Terminal with sqlite3: sqlite3 LONG_FILE_NAME.db

  4. Type select app_id from app_info where bundleid = 'com.apple.appstore'; and then hit return. A number will be displayed.

  5. Then delete all the notifications from the app store. delete from notifications where app_id = NUMBER_FROM_PREVIOUS_STEP;

  6. Finally, you might need to kill NotificationCenter. That was the only way to remove an existing notification off the screen. Type killall NotificationCenter in Terminal.

Here is an example of using sqlite3:

sqlite> select app_id from app_info where bundleid = 'com.apple.appstore';
sqlite> delete from notifications where app_id = 8;
sqlite> .q

I'm not sure how long it will last, but it has been a great afternoon without that notification nagging me all day.

  • 1
    Nice research job! I'd prefer to be able to make it stop entirely, but this is good to know.
    – TJ Luoma
    Commented May 16, 2013 at 14:08

Go to systemPreferences > softwareUpdates and then uncheck everything you see.

  • Doesn't this suppress updates on a "corrective action taken" after the notification has been shown instead of being able to suppress tomorrow's updates as the question seems to imply? Perhaps @g is OK with seeing the first notification and then suppressing it and that's just my preference shaping how I read the words, though.
    – bmike
    Commented Mar 9, 2013 at 17:02

Click on the icon to the right of the spotlight. Then scroll all the way to the top. It will display "Show Alerts and Banners On". Simply turn it off, and the alerts will disappear for the rest of the day.

  • Good tip, I didn't know about that. Not exactly what I was looking for but helpful to know.
    – g .
    Commented Apr 19, 2013 at 15:47

If you hover over the notification and swipe from the left to right on the trackpad (assuming you have one), it will be moved to the notification list and off of your immediate screen.

  • 2
    The notification reappears shortly after you do this - which is mentioned in the question.
    – Dan J
    Commented Jan 14, 2013 at 20:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .