3

Has anybody encountered a problem with the USB driver when running Windows 7 on MacBook Pro 2010 (MC371)?

It doesn't recognize any USB drives or USB hard drives. I've tried both Windows Update and Bootcamp update - nothing helps. Where can I find a proper driver?

6
  • Strange, because it should use the Intel chipset drivers to run the USB. Have you updated to the latest Boot Camp?
    – user479
    Jan 30, 2011 at 4:37
  • yep, I've updated it inside windows to version 3.2 and have checked and updated windows itself, but it didn't help
    – knuku
    Jan 30, 2011 at 8:23
  • 1
    I don't suppose you've tried calling Apple support? This seems like the kind of thing they might be able to help with...
    – Ciaocibai
    Feb 2, 2011 at 8:50
  • I'm having the same problem. Was this resolved?
    – user15436
    Dec 23, 2011 at 7:49
  • nope, all the solution proposed didn't helped and I don't have any Apple Support in my country
    – knuku
    Dec 23, 2011 at 11:26

4 Answers 4

1

Is your Windows 7 64-bit? If so, you might want to install the drivers in the Mac OS X DVD.

D:\Boot Camp\Drivers\Apple64.msi

1
  • I have no such path on my Mac OS DVD. Actually, there were some chipset drivers, I've tried all of them but nothing helped.
    – knuku
    Feb 10, 2011 at 14:07
1

Try to Uninstall the USB host drivers using device manager and then "Scan for hardware changes" to re-install them.

Might not work but its worth a try.

0

The drivers that come with windows should work already. Bootcamp doesn't install any new driver USB-wise.

Most likely you got a bad windows installation. I would try the same disc on another machine just to be sure.

edit: Unless, of course, it's not an issue with the USB itself. Here's a good troubleshooting guide from microsoft. The only thing that it says about the USB itself is that it may be defective - even if it works on Mac. Hardware issues can be quite complex.

6
  • I'm sure installation is OK. A system from the same disk works fine on another machine
    – knuku
    Feb 3, 2011 at 16:12
  • @NR4TR touche. I now suppose as well the USB works fine on OSX. If so, I'm out of ideas!
    – cregox
    Feb 3, 2011 at 19:12
  • It does work fine :)
    – knuku
    Feb 7, 2011 at 7:57
  • As @IntuitionHQ said, it may be a hardware issue and apple care would replace your mbp for you. Tried calling the support?
    – cregox
    Feb 7, 2011 at 13:19
  • this is not a hardware issue. in mac os everything works fine. it's a windows driver issue, but i hardly can find any drivers.
    – knuku
    Feb 8, 2011 at 7:39
0

Finally, I've got the solution. Yesterday I've updated both Win 7 and Windows Bootcamp, and the system found the hardware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .