I like keyboard navigation, so I frequently use Shift-Command-G to Go to Folder… when saving files. I type the first few letters of the directory I want then key Tab to complete the rest. This worked consistently on my old MacBook Pro with Snow Leopard.

On my new one with Mountain Lion:

  • tab completion works about half the time
  • the other half, keying Tab is ineffective.

I've observed this with Finder, and with Save dialogs in TextEdit and Firefox. I've carefully verified the spellings, and paths to the directories.

I've also seen it go from not working to working without my doing anything noteworthy in between (didn't reboot, quit and restart the program, or quit any other programs).

Added information:

  • The asynchronous progress indicator is not spinning while this happens.
  • This is not an issue only with ambiguous tab completions (when there's an ambiguous stem, it usually just autocompletes with the first match alphabetically.
  • This does not involve files on an external drive.
  • If I type in the full name of the directory I'm trying to autocomplete, the "Go to Folder" dialog will not go there (it acts as if I typed in a nonexistent folder name). However, I can still navigate there manually using the save dialog.
  • Nothing appears in the Console or the system error log at times when this error occurs.
  • At Graham Perrin's advice, I ran mddiagnostic, but I have no idea how to interpret the output beyond the system error log I already examined.
  • Is it possible there are multiple possible matches when you notice this behaviour? Like ~/Do(cuments|wnloads).
    – Gerry
    Nov 25, 2012 at 7:59
  • Normally when there are multiple matches it autocompletes with the first one alphabetically -- which isn't my favorite behavior, but it definitely does something. I've seen it fail on both ambiguous and unambiguous matches (and later work on those same matches).
    – octern
    Nov 25, 2012 at 14:03
  • Or on an external drive perhaps?
    – Gerry
    Nov 25, 2012 at 14:30
  • No external drive involved.
    – octern
    Nov 25, 2012 at 20:44
  • The new ambiguous-autocomplete behavior annoys the crap out of me. I'm used to it being like the UNIX shell - having to backspace out from the (usually VERY LONG) incorrect completion makes it take longer and more typing than it'd have been to just type the full name manually to begin with. So if this could be configured back to how it used to be, that'd be awesome.
    – fluffy
    Aug 9, 2013 at 22:45

1 Answer 1


If the asynchronous progress indicator spins, in the sheet, immediately after you key Tab then something is ongoing and you can wait for the operating system to get what it needs from the file system.

For example, a wait of maybe seven seconds between the following screenshots:

an asynchronous progress indicator progress completed

If the problem is without a progress indicator, then see whether the Console view of all messages presents anything of interest at the time of the problem.

If nothing of relevance is visible in Console, then you can run mddiagnose to gather information, some of which may help someone to diagnose.

mddiagnose(8) OS X Manual Page

  • Thanks for the great screenshots. Yes, I've seen that indicator from time to time, and when it shows up then something typically happens eventually. On the occasions I'm talking about, there's no indicator and no response to the tab key, even after waiting. I'd double-check this, but unfortunately I haven't figured out how to replicate the problem at will.
    – octern
    Nov 25, 2012 at 20:38
  • Now confirmed that there is definitely no indicator when the problem occurs.
    – octern
    Nov 26, 2012 at 5:26
  • Nothing appears in the system error log or Console when the problem occurs. (I can now also confirm that it persists through multiple reboots).
    – octern
    Nov 30, 2012 at 3:58
  • Thanks. Consider adding to the opening question; it may help other readers to add a better answer. Nov 30, 2012 at 7:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .