I'm owning a MBP 15" early 08, which I bought (and use) in Germany.

Recently, I decided to switch to US International layout, bought new keyboards (an internal one and and external Logitech diNovo Mac), both having US 104 keys layout.

The internal keyboard is working fine, I'm able write the ` and ~ characters.

On my external keyboard, these keys post ±/§ (so the UK equivalent). Also, the on-screen-keyboard shows a 105-keys-layout, but it is correctly set to (104 keys) US extended:

on-screen keyboard layout

Seems I need to convince my Mac I've got 104 character keyboards, but I cannot find any preferences.

Also, when entering my file vault password in firmware mode, I've still got a German keyboard layout which I'm not able to change.

  • Note that US Extended and all other keyboard layouts automatically fit both 104 and 105 key keyboards. Commented Nov 25, 2012 at 20:46
  • It is really odd for a machine to see one hardware keyboard as 104key ANSI and another as 105key ISO. Can you test some other hardware keyboard to see if the problem is isolated to the one you are currently using? There is some info about keyboard type problems at m10lmac.blogspot.com/2009/12/fixing-keyboard-type-problems.html Commented Nov 25, 2012 at 20:48
  • Deleting the config file or using the keyboard wizard don't help. I guess the on screen keyboard showing 105 character layout is some part of the problem. I also don't understand why the internal keyboard is working fine but not the external, probably either Logitech or Apple messed around with their drivers and don't care for the keyboard layour set up...
    – Jens Erat
    Commented Nov 25, 2012 at 23:45
  • In system preferences/language & text/input sources, is there Logitech layout where you can check or uncheck the box? What does the onscreen keyboard look like when you switch to US International PC with the "flag" menu at the top right of the screen? Commented Nov 26, 2012 at 13:17
  • There is a logitech layout which I can check, but not select using the menu item. US International PC also shows 105 keys keyboard. I just realized: When unplugging the USB receiver for the keyboard, displayed layout switches to 104 keys (but without numpad, representing my internal keyboard).
    – Jens Erat
    Commented Nov 26, 2012 at 14:47

2 Answers 2


One possibility is to use keyremap4macbook, but this doesn't change the firmware keyboard layout and I don't like fiddling around with such tools if not necessary.

Change keyboard layout


The problem solved itself when I upgraded to Mavericks and changed my user password. Sadly I didn't check if it's working in-between, only realized I do not need keyremap4macbook any more.

It might be possible resetting the PRAM resolves the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .