6

Sometimes, when I'm working with Finder (Mac OS X 10.8), with a folder in Column View, I suddenly notice that the separator between columns has changed to a thick one like this:

enter image description here

When this happens, I cannot drag the separator to resize the columns. I haven't found a permanent fix apart from it seems to go away again after a while.

Edit (clarified question):

Almost certainly I have just enabled some mode or other, but I don't know what I've done. What causes this and how do I turn it off?

11

This happens when that separator needs to accomodate space for a scroll bar due to content length. You can resize them with the handles at the bottom end since 10.0.

Column View separator with resizing handle at the bottom.

  • I'm confused; a horizontal scroll bar, a vertical one? Which content are you referring to? I'm looking at a Finder window now with a scroll bar in it and not the blocking separators I described... – Andrew Ferrier Nov 22 '12 at 10:12
  • I was referring to the need for vertical scrolling due to content length. Horizontal scrollbars never affect columns. – MacLemon Nov 22 '12 at 10:52
  • Hmm, that's not my observation. I have a window open at the moment with several columns which are longer than the window (and where I see scrollbars appear when I drag my mouse). But (at the time of writing at least) these don't have the thick bars between them. What triggers that? – Andrew Ferrier Nov 22 '12 at 11:40
  • 1
    Thanks for the point about the resizability; I'd missed those grab handles. – Andrew Ferrier Nov 28 '12 at 23:28
7

I can confirm that Lauri Ranta's solution above fixed this issue for me.

System Preferences -> General Preferences -> Show scroll bars: "When scrolling"

Like Andrew mentioned, this problem seems to come and go. On my machine, I wonder if the setting "automatically based on mouse or trackpad" is getting confused as I switch between a Razer mouse and the Apple trackpad. Might be worth a look if you have a similar setup to mine.

  • OK, thanks. Have changed to that setting, will see if the issue recurs. – Andrew Ferrier Nov 28 '12 at 9:18
  • 1
    Andrew, I think it'd be helpful for Lauri if you indicate her answer is the "correct" answer. It will help her "reputation" and it will help future readers quickly find the answer to your question. – Dane Wendell Nov 28 '12 at 15:31
  • 1
    All of a sudden this began happening to me and I don't recall changing my scroll settings. Weird – Brad Thomas Nov 18 '15 at 20:20
  • This should be the accepted answer! – Logan Yang Apr 22 at 0:57
3

Have you tried changing the setting for showing scroll bars in the general preference pane?

  • In my preference pane, I have it set to the first value. How would this affect my situation? – Andrew Ferrier Nov 23 '12 at 9:16
  • @AndrewFerrier That's the default. Normally it would make OS X use the legacy scroll bars when a mouse with a scroll wheel (but not a Magic Mouse) is connected. If the second option is selected, the transient scroll bars are used even then. – Lri Nov 23 '12 at 9:20
2

I have the same problem and recently dicovered that having an external (non apple) mouse connected has an affect on the problem. I don't know the solution but the problem seems to occur only when I plug in an external mouse. Unfortunately it adjutsts finder's appearance wether it's connected or not to the mouse and only lets you change column sizes in finder if you use the rtackpad only. (MBP)

0

I had the same problem, and Andrew was right, but I was using Apple Magic Mouse. So, I tried to switch off the bluetooth that my mouse was connected to, then using the trackpad, I could resize the column in Finder. I turned back on the bluetooth and the problem of resizing the columns has gone. I have to make a remark that my magic mouse was also low on battery. (MBP 15, OSX Lion)

0

Try restarting Finder service by the following commands:

launchctl stop com.apple.Finder
launchctl start com.apple.Finder
0

I find in MacOS 10.14.5 that when System Preferences -> General Preferences -> Show scroll bars -> "When scrolling" is set, you can resize columns as normal, but when Show scroll bars is set to "Always", you have to use the widget at the bottom of the scrollbar - as mentioned in other answers.

It seems odd, however, that when "When scrolling" is set, the content is bigger than the height of the column, and you start to scroll so that the scrollbar appears, while the scrollbar is visible you can still resize the column via the normal method (i.e. instead of using the widget (which doesn't appear in this case)) - why don't Apple just make the columns resizable via the normal method all of the time?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .