I was trying to install Microsoft Office 2011 when the installer hanged (and it is not going anywhere, I waited about 12 hours before trying to reboot this macbook). Now I can't restart this macbook until the installer finishes.

Is there a easy way to locate what process is preventing my mac from restarting?

Error dialog

  • When I asked the question I forgot that I could do a "sudo shutdown -h now" to really force my mac to shutdown (it is a better way to shutdown instead of power button), but that answers "how to force a shutdown/restart", not how to find the process that is preventing the shutdown.
    – grprado
    Nov 20, 2012 at 13:30
  • Same problem here, same software being installed.
    – Chords
    Mar 3, 2013 at 17:11

4 Answers 4


Killing "installd" with Activity Monitor seems to have fixed the problem for me.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post.
    – Tetsujin
    Dec 3, 2014 at 20:32
  • Um...yes it does. The question is "Is there a easy way to locate what process is preventing my mac from restarting?" The answer is "Yes," but that seems a bit terse, so I said how to find and kill the offending process. My answer might be wrong, but it is responsive to the question.
    – Calion
    Dec 4, 2014 at 21:21
  • @Calion killing installd does help me to temporarily solve the problem, but now it will occur everytime I shut down my laptop which is very annoying. Do you know how can I remove it permanently? Sep 13, 2020 at 11:06
  • Hm. Yes, that would be a problem. No, I don’t have any specific advice, but the first step in this sort of situation is always to check the disk with Disk Utility (or TechTool Pro, or fsck, etc.).
    – Calion
    Sep 14, 2020 at 21:19

You could just force your computer to switch off and then restart it. Just push the "Power On/Off" button for a few seconds.

You could also open the Activity Monitor application and check if there is a corrupted process.

  • 2
    Power on/off for a few seconds just do a very dirt shutdown and thats what I am trying to avoid.
    – grprado
    Nov 20, 2012 at 13:27
  • @grprado - I do it pretty regularly (ever week or so. My mac crashes more then my PC!), and have not had any problems yet.
    – Fake Name
    Nov 26, 2012 at 16:54

I had the same problem with Google Voice and Video:

Your computer can't be restarted now, because software is being installed.
Google Voice and Video is being installed. Interrupting the install may damage your computer. You can restart when the install is complete.

First of all, find the process PID in Activity Monitor or using ps wuax in Terminal e.g. by: ps wuax | grep install. If you can't find it, try to move the window as fast as possible and check which process takes CPU time.

In Activity Monitor you can actually take a Sample of the process what's doing. Or by debugging it from Terminal sudo dtruss -fp 1234

If this does nothing, try to send hang up signal first to the process what it would do by (replace 1234 with your Process ID number):

sudo kill -HUP 1234

then if nothing happens, try to kill it softly by:

sudo kill 1234

if it's still not killed, then try it hardly by:

sudo kill -9 1234

Other method is to use xkill if you've this tool installed:

  1. Run: xkill
  2. Click on the window which you want to kill.


Another easy method is to press Alt+CMD+Esc, then popup should appear, and you can select and kill the process.

  • xkill is not available by default.
    – nohillside
    Aug 2, 2013 at 14:52
  • 1
    Thanks, I didn't realised that. I had this installed with X11.
    – kenorb
    Aug 2, 2013 at 15:52

The Microsoft Office Installer should have an icon in the Dock, just right-click it and choose "Quit" for hold the option key and choose "Force Quit" then shutdown or run the installer again. I have had to do that a couple of times due to hangs during the Office 2013 install, although I did not do a shutdown, just force quit and run installer again has worked for me.

EDIT Since this does not work for you you can use the Activity Monitor or "ps -ef" to find the processes and kill them.

  • I alread did that, the problem is that MS Office installer starts other processes not linked to the installer. Force quit the installer doesn't kill these processes. By the time I took the screenshot the installer was killed a long time ago.
    – grprado
    Nov 20, 2012 at 13:55
  • Ah, that is an issue I have not seen. You can use the Activity Monitor or "ps -ef" to find the processes and kill them. Nov 26, 2012 at 15:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .