Is it possible to change where macOS Notification Center alerts appear on the screen?

They currently appear at the top right of the screen with the menu bar:

Notification Center alert at top right of screen, covering a browser window

Alerts appearing in the top right tend to cover up work I'm doing more often than not. They cover up browser tabs, toolbar icons, and window titles.

I would prefer, say, the bottom right corner of the screen.

If moving the alerts is not possible, is it possible to change the screen on which they appear?


Unfortunately, you can't change the screen position of the Notification Center Alerts and Banners. This is a huge gripe of mine as well, and I highly encourage you to complain about this issue to Apple here: http://www.apple.com/feedback/macos.html

Hopefully they will one day change this. I also have not been able to find or formulate any hacks.

I, too, am annoyed by it covering up controls in my modeling applications, tabs in my browser, etc.

You can move the Notification Center to another screen, however your entire menu bar goes with it. When you have more than one monitor active, open up System Preferences > Displays > Arrangement. Click and drag the white bar inside one of the squares representing your current primary monitor and drag it to another monitor.

For notifications that don't need immediate attention, consider changing the alert style from Alerts to Banners. Banners are automatically dismissed into the notification center where you can find them later.

Good luck, and keep spreading the word that we need to tell Apple to make this experience better.


Swipe with two fingers on the banner pop up and it will remove it. Not the best answer but convenient for when I need to access a control or tab.

Source: http://www.cultofmac.com/189192/


You can adjust the time the notification is displayed on the screen:

In a terminal window type:

defaults write com.apple.notificationcenterui bannerTime SECONDS

Where SECONDS is the number of seconds the notice will remain visible. Default is 5 seconds.

Log out and in again to activate the setting.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .