I just purchased Microsoft Office 2011 for MAC and installed it on my rMBP OSX 10.8.2 running Mountain Lion. The installed version from purchase is 14.2.0. I tried installing 14.2.3 but it failed due to a specific file that was not found :

Office 14.2.3 can't be installed on this disk.
A version of the software required to install this update was not found on this volume. 

So I went to the site and downloaded 14.2.1, but that didn't install either with the same message. Also tried 14.2.2, but still the same error.

I want to add that the actual installation failed (tried twice), however Office 2011 appeared in the application folders and Word works fine.

Not sure what can be causing this, any idea ?

  • I encounter the same problem. May I know after the cleanup and re-installation, do you need to register the product key again?
    – user43379
    Feb 21, 2013 at 3:44
  • @IvanH I cannot remember exactly, but a clean uninstallation did prompt me to enter the product key again. If you did not delete every single file related to MS, then the product key might still be registered and you may not need to re-enter it.
    – Render
    Feb 21, 2013 at 12:13

3 Answers 3


I had this issue once. I ended up backing up my data via Time Machine (for a get out of jail card) and then removing Office in it's entirety, rebooted my Macbook Pro, and then proceeded to reinstall Office 2011. Once I had the Office suite reinstalled the software allowed me to apply all subsequent updates without issue. This worked for my particular instances / issue, results may vary depending on software environment.

  • Surely there should be an easier way to fix this ?!
    – Render
    Nov 18, 2012 at 18:20
  • There may possibly be but when I was searching for a solution I did not find one. The OSX version of Office does not have a built in repair function as does the Windows version of Office. This may be because its not a common issue. Strictly a theory mind you.
    – Mort
    Nov 18, 2012 at 22:47
  • How did you remove office 2011 ? I tried many various ways on the internet as well as the official Microsoft website but installation always fails (yet word runs fine), and any subsequent updates completely fail to install.
    – Render
    Nov 25, 2012 at 21:02
  • I used AppCleaner which you can download from here: (freemacsoft.net/appcleaner). It worked well for my particular issue anyway.
    – Mort
    Nov 26, 2012 at 16:51
  • I did use AppCleaner .. I think my issue is deeper unforutantely ... Did you just click on the Word app through AppCleaner and thats it ?
    – Render
    Nov 26, 2012 at 16:54

My guess is that problem is based on the initial installation having failed, and that the only way to fix it would be to forcibly remove all of your Office-related 'receipts' and try again.

Note: THIS IS POTENTIALLY DANGEROUS AND I CANNOT PROMISE THAT IT WILL SOLVE THE PROBLEM. That being said, I tried it on my 'test system' and it appeared to work. FOR ME. YMMV.

1) Move all of your 'com.microsoft' receipts to the Desktop:

sudo mv -vf /private/var/db/receipts/com.microsoft.* ~/Desktop/

2) Download and reinstall Microsoft Office 2011.

Note that I have written a shell script to help facilitate this. You can find it at https://github.com/tjluoma/office2011/blob/master/office2011.sh

Assuming you are comfortable with the Terminal.app, you can use the script like this:

cd ~/Downloads/

curl --location --remote-name https://raw.github.com/tjluoma/office2011/master/office2011.sh

chmod 755 office2011.sh


That will download the official DMGs from Microsoft and use the official command-line package installer from Apple. Which means that it will not install if it finds matching receipts at /private/var/db/receipts/com.microsoft.*

I strongly encourage you to ONLY try this IF you have a verified backup of your enter boot drive (SuperDuper or CarbonCopyCloner, not just TimeMachine).

  • Thank you for replying. Why do I need to backup ? Is there a chance for this to corrupt my drive ?
    – Render
    Jul 25, 2013 at 7:09
  • Well, if you move them to the Desktop, you should be able to move them back, but anytime you're tinkering around under the surface it is a good idea to have a backup just in case. A typo in the Terminal can be a bad thing. 99 times out of 100, or more, you'll have no problem, but better to be prepared and not need it than wish you had taken a few minutes to update your SuperDuper clone beforehand!
    – TJ Luoma
    Jul 27, 2013 at 2:24

Its easy. Rename the folder where office resides back to Microsoft Office 2011. You probably changed it before hence it cannot find.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .