2

If you double click a word to select it, and keep the mouse held down, you go it starts word selection mode, meaning it will select whole words as you move the mouse over them.

This only works when using the physical click on the trackpad. The problem is that I want the same behavior using a tap (i.e. the One Finger Tap to Click feature is enabled). When I try to use a tap, though, it goes into character selection mode rather than word selection.

Is there ant way to perform word selection using tap gestures on a trackpad?

2
  • check out bettertouchTool. Not positive, but I bet there's something in there that would do this. Jan 29, 2011 at 3:06
  • @Calavera: I installed it and played around with it's settings for other problems I have. I don't see any settings that might help with this problem though.
    – Senseful
    Jan 29, 2011 at 3:37

4 Answers 4

6

Yep!

You double-tap and lift off to select the word. Then double-tap the selected word and start dragging immediately keeping your finger down. It's actually kind of tricky to get to work without dragging the word but once you get it a couple of times it gets easier.

Here's an explanation on how to do it also from macworld.com, same as above:

To select text (and this works in nearly any program that involves text) on a word-by-word basis, do a double-click-and-hold before you start dragging, instead of a single click. As you move the mouse along now, you’ll see that entire words are added to your selection as soon as the cursor touches their first character. So if you’ve got a fair bit of text to select, but still need precision, this is a pretty quick way to get it done.

Here are my trackpad settings

enter image description here

13
  • That causes the word to be dragged rather than highlighting
    – Senseful
    Jan 29, 2011 at 2:17
  • it doesn't do anything at all for me except unselect the word Jan 29, 2011 at 3:05
  • You have to start the drag almost immediately after the second double-tap. It works believe me, I just did it. I know if you delay at all it drags the word instead. I added a link to macworld.com explaining it too Jan 29, 2011 at 4:09
  • @calavera: I was able to reproduce that result if I disable one finger dragging in the settings. @Griffo: If I use clicks instead of taps, everything on the macworld article works as described. However, it does not work with taps no matter how many times I try or how fast I do it.
    – Senseful
    Jan 29, 2011 at 4:32
  • I just tried it with clicks instead of taps and it worked. click-click-pause click-click-drag works for me. You need 'Tap to Click' enabled in preferences. Do you have that enabled? Jan 29, 2011 at 4:36
2

I'd try using the three finger dragging method. In the Trackpad System Preference, set Three Fingers to Dragging. Double-tap a word to select it, then use three fingers to drag from that word to highlight more words.

2
  • That works. Unfortunately, though, I like the navigation gesture with three fingers, so I don't want to rebind it.
    – Senseful
    Jan 29, 2011 at 4:27
  • This does indeed work in macOS Sierra, but is very tricky to get right. Most of my attempts result in whole-paragraph selection. Apr 19, 2018 at 7:10
1

Double tap this word. Then hold shift and double tap this word.

7
  • I'm looking for a solution that doesn't need a second key/hand.
    – Senseful
    Jan 29, 2011 at 4:24
  • 1
    @Senseful: i don't think you even need a double-tap at the end. it selected for me with a single tap on the second word. Jan 29, 2011 at 4:46
  • @calavera: yeah, that's true.
    – Senseful
    Jan 29, 2011 at 5:05
  • @calvera: true, but double tap means you can be less accurate about cursor position (anywhere in the word rather than exactly at the end). Fitt's Law rules.
    – bahamat
    Jan 29, 2011 at 16:51
  • @senseful: press shift with your pinky and double tap with your thumb? ;-)
    – bahamat
    Jan 29, 2011 at 16:52
0

On my MacBook I can triple tap (keeping the finger on the pad on the third tap) and drag to use whole word selection.

I can also quadruple tap to select the entire paragraph.


My trackpad settings: trackpad settings

6
  • That's weird... after reading what you wrote, I tried it and it worked, however that was the only time I could get it to work. No matter what I try, I can't get the same results.
    – Senseful
    Jan 29, 2011 at 4:23
  • @Senseful: same here, except it didn't even work once Jan 29, 2011 at 4:50
  • Perhaps this is almost same as what @Griffo has said, but for me the other one was easier to do. I am not very good with taps..
    – Nivas
    Jan 29, 2011 at 4:50
  • Added trackpad settings for my MacBook for reference, as I have an older machine than @Griffo
    – jtjacques
    Jan 29, 2011 at 4:57
  • @jtjacques: are you on Leopard (10.5) as well? Jan 29, 2011 at 5:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .