I'm trying to create a service (in this case, operating on images in Evernote.app).

I open up Automator, make my script, and set it to to receive 'image files' in 'any application'. Doesn't show up either in the menubar (Evernote > Services -> "My Image Service"), or in the context-menu (Right-click image, services are at end of menu).

Changing the selection to: no input, files, files or directories, etc. makes no difference. Changing the application to Evernote.app makes no difference.

The thing that makes me think I'm missing something: if I set the application to Preview.app, I also can't get any services to appear in the menu bar. Is there something I have to do to trigger their appearance there?

(EDIT: my question got cut off for some reason - fixed that)

  • What is it exactly you are trying to get the service to do? Services will only show up in the services menu if the correct input type is present, and if the application supports it.
    – soxman
    Nov 16, 2012 at 0:18
  • Doing a test for this shows that Evernote makes available only a limited set of services. I created a quick service to make a contact sheet from selected images. It worked from the Finder, but not from selected images in Evernote. I am not sure about why this is or how to circumvent it, but it is clearly restricted by the application itself.
    – soxman
    Nov 16, 2012 at 0:27
  • @soxman Specifically, I'm trying to make a service that will take a selected image and scale it down, greyscale it, etc. I tried setting the Service to accept "no input" though, and it still won't show up in the Evernote.app menu. See my last paragraph - I don't think this is directly related to Evernote.app. Nov 16, 2012 at 0:52

1 Answer 1


Make sure that the service is being saved to ~/Library/Services as a .workflow file. It only seems to include Services in the menubar when they are saved to this path.

Additionally, ensure that the Services folder is not an alias to another folder. It should show up as a normal folder in finder. I had a similar problem and was able to resolve it by removing the alias I created in ~/Library/. Instead of my Services alias, I created the Services folder as a normal folder. Once I did that, every script that was saved there began to appear in the menu as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .