4

Is there a way to disable the wifi popup window that was introduced in OS X Lion.

I know I can remove it from known wifi networks, but sometimes I do use this connection (It's the Starbucks free wifi next door). The problem arises when I am using Ethernet and maybe it flakes out, or OS X is doing something else, but It pops this window up to let me connect to the free wifi hotspot. I'd much rather have to do this manually (Using my web browser) rather than the "always on top" popup window it gives me.

I've looked around on the internet and have found no solutions, I was kind of hoping some network guru for sound defaults write blah.blah to disable it.

See image below for the popup window I'm seeing:

enter image description here

3

While littlerock's answer works, there are better options. Specifically, you can do one of the following. The order is what I would recommend:

  1. Change the system setting. This is preferred, as it's using the OS as designed. Do this on the console and provide your password:

    sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.captive.control Active -boolean false

  2. Prevent OSX from detecting the fact that we're on a captive portal, by editing the hosts file. Apple uses their domain to test whether we are on the Internet or not. To do this, edit the following file as root with a text editor:

    /etc/hosts

    127.0.0.1 captive.apple.com

  3. Last, you can follow littlerock by renaming the following file (as root) to whatever you like:

    /System/Library/CoreServices/Captive Network Assistant.app

  • Unfortunately, the preference in 1. does not appear to exist in Mojave. – jpgeek Mar 21 at 5:21
-1

Check this link. It works for me.

https://discussions.apple.com/thread/3308224?start=0&tstart=0

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • explain brief answer here. Link can be gone some time. – Eir Nym Mar 18 '13 at 9:02
  • 1
    This esentially disables Captive Network Assistant.app Which lives at /System/Library/CoreServices/Captive Network Assistant.app -- the solution proposed is to rename that app to something like XCaptive Network Assistant.app so it can't run. Ideally we could disable, but this hacky work around probably works (though I haven't used it) – Byron May 8 '13 at 17:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .