I dont know what has happened, but today user control with mouse and trackpad on my macbookpro is screwed up.

I rebooted twice, it made no difference.

The trackpad moves the cursor okay, but I cannot get tapping or clicking the trackpad have any effect.

With my mouse I can access menubars, but the left and right buttons are swapped round. I then went to the System Preferences screen to try and fix the mouse preferences, but clicking on any icon with left or right button has no effect.

I then found no icons of that type seem to work, I thought Id try and just update OSX with any updates available hoping that would fix anything that has got corrupted. But although I can get to the Appstore Update screen and there are two updates available I cannot get the updates installed. Clicking with the left button does nothing, clicking with right button changes the colour of the button slightly so the bottom half is in gray but nothing else happens.

As there is no menu option to install the updates I thought I tried and install the updates using the keybaord but I cannot work out how to do this.

Help Please !

  • 1
    Have you already tried to boot in safe mode? Would be interesting to know, if it is working within this mode. Booting into safe mode: Shut down your Mac and wait 10 seconds. Press the power button. Immediately after you hear the startup tone, hold down the Shift key. You should press the Shift key as soon as possible after you hear the startup tone, but not before. Release the Shift key when you see the gray Apple logo and progress indicator (spinning gear).
    – cyphorious
    Nov 13, 2012 at 12:37
  • Hi, Ive just tried in SafeMode and it still doesnt work Nov 13, 2012 at 13:12
  • Contact Apple, they know of it and if you are lucky they will replace it for free.
    – Ruskes
    May 11, 2014 at 19:20
  • I would suggest to try the Apple Hardware test.
    – Ruskes
    May 11, 2014 at 19:21

1 Answer 1


I'm not sure about the answer, but my suggestions are too long for a comment. So I will create an answer nontheless.

First: Installing updates with the keyboard should be easy if you are able to launch the app store. When you are in the appstore, use your "tab"-key to go through the main menu. Hit "space" to enter the selected item. Hitting the tab key again will bring you to the other items in the window (like the "update"-button).

If updating does not solve your issue and you are sure that there is no Magic Mouse somewhere in your bag or whatever, which is accidently turned on and can cause issues, you could try to reset NVRAM. This article should be interesting to you: https://discussions.apple.com/thread/4061591?start=0&tstart=0

  • I tried the AppStore Updates , but although I can get on the Update page pressing the tab key just takes me to the search box and im unable to get anywhere else. Then I think i did the NVRAM reset it doesnt inform me , but I held down the keys before starting, computer started and then restarted and I released the keys but it made no difference. I then tried AppStore Update again, and a combination of pressing other mousekeys somehow I got it to start, but now I being askked to accept a license agreement, and nothing I do have any effect on the 'Agree' (or 'Disagree') button Nov 13, 2012 at 14:52
  • Before I saw your reply I thought maybe the trackpad had got wet so I undid the case ands unplugged the battery using this video youtube.com/watch?v=42qcvlftmcM and looked underneath it but there was so sigh of water. This then caused problems on reboot because datetime was now wrong, but I did eventually manage to change this in preferences because the preferences search box actually allows you to open a preference by finding it in the searchbox. I set Date/Time, then checked Mouse and Trackpad there wasn't anything weird about their settings. Nov 13, 2012 at 14:58
  • Made some sort of progress, when using a 3button mouse, the right button works, brings up popmenus ectera, and the middle button (which I never usually use) also seems to work in that it lets me select items brough up in popupmenus, but unfortunately the left clik button never works. So in App Store I can start Update, by right clicking on the button and then using middle button, but unfortunately when I get to the agreement dialog, none of the button will let me select the Agree button Nov 13, 2012 at 16:21
  • Oh man, I had this idea of both disabling the trackpad in Asseccisibility and of enablign voice activated commands but in both cases there seems to be no way of changing these values with my broken mouse/trackpad setup Nov 13, 2012 at 16:32
  • Eventually after considerable clicking attempts on trackpad I got the OSX update to apply, but unfortunately it has made no difference and the problem persists in both normal and safe mode. Nov 13, 2012 at 21:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .