Has someone else this kind of problem after yesterday's update for July'12 Macbook Pro?


I have tried all the typical things like Reboot, Restore Disk Permissions, killall SystemUIServer. The one thing that does fix this issue is making a new user account. When I log in to that account, the icons are revealed.

  • What have you tried to fix this? Reboot, safe boot, trying to log in with a new user account?
    – bmike
    Commented Nov 12, 2012 at 14:10
  • Also - I've heard of this failure before out of the blue. Have a look at this thread
    – bmike
    Commented Nov 12, 2012 at 14:15
  • Tried all the typical things such as: Reboot, Restore Disk Permissions. Other accounts get all the things right Commented Nov 12, 2012 at 14:15
  • bmike - thank you, but reinstall OS isn't what i want to get here :) Commented Nov 12, 2012 at 14:16
  • Edit the things you tried into your question. I'll have an answer for you :) (And reinstalling won't fix this sort of user level corruption)
    – bmike
    Commented Nov 12, 2012 at 14:18

3 Answers 3


rebooting in safe mode, and rebooting in normal mode solved exact same problem for me (it is method suggested in thread mentioned above My Retina MacBook Pro is missing some icons suddenly! What happened?)

  • Good use of a safe mode boot to run several clean up items as well as to just restart the OS.
    – bmike
    Commented Feb 10, 2013 at 21:27
  • rebooting in safe mode helped me when it happen again. Thank you! Commented Mar 17, 2013 at 7:00

The step where you tested with a new account has shown that your corruption is simply to the user settings and preferences and not some problem with a systematic bug or a conflict between software.

Sadly, you have several programs with corruption according to the screen shot and you may need some time to figure out exactly which settings are causing you grief.

To start - estimate how much time you will need to just move your documents over to the new account and write that estimate down. Also start a full backup to ensure you have a good recovery point.

Then spend one third to one quarter of that time clearing settings, looking to delete preference files/that are related to the affected corruption.

The menu bar icon location is stored in ~/Library/Preferences/com.apple.systemuiserver.plist

So, you can start with these two articles and the step above to see if you want to try and fix each of these issues by re-creating the affected preference files by dragging them to the desktop (or the trash) and rebooting:

Once you've spent some time fixing each item you have noticed breaking, you can check with your original estimate on how long it would have taken to just start moving your documents over and re-choosing your settings. Hopefully, you picked the shorter route to clearing this corruption. The benefit of just starting new is you don't have to notice all the things that are wrong and hunt them down one by one. You will remember you like this desktop picture and that layout and change the things you care about quite easily over time.

  • Thank you a lot, Mike! Already have moved to another account Commented Nov 12, 2012 at 17:26
  • Rock on! I'm a big fan of making new accounts regularly but it's not the best for some cases.
    – bmike
    Commented Nov 12, 2012 at 17:32
  • The same issue after one day on another account. Will reinstall OS :( Commented Nov 13, 2012 at 17:11
  • Try to keep a small paper log just to document what happened, what you did, when things broke. Sometimes that helps narrow down the cause and I'm getting the feeling you either have multiple small problems or perhaps the hard drive is beginning to fail. Keep your backups clean, current and protected.
    – bmike
    Commented Nov 13, 2012 at 17:26

So I've had the same problem for quite some time now, and I have been googling around a lot.

In the end I found out that the problem seems related to hibernation/deep sleep and virtual memory.

The problem on my machine was that the swap was disabled and the graphics problems occurs after a wakeup from deep sleep.

Only way to temporary fix this was to reboot the mac into my account in single user mode (holding shift while booting), and then back to normal mode.

The permanent way to fix it is to reenable the virtual memory kernel again.

So starting the virtual memory kernel is done by running :

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.dynamic_pager.plist

Also on my mac the reason the virtual memory wasn't running was because the file com.apple.dynamic_pager.plist for some reason was deleted/missing.

So I restored it from my Time Machine backup and rebooted.

And it all seems fixed now... finally!

Let me hear if this helps others!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .