I'm using my Google account to sync my calendars. The iPad shows duplicate entries, but my phone and Mac do not, as you can see:

calendar with duplicate entries

What exactly am I doing wrong? I've tried removing every account and restarting and adding but still the same.

NOTE: I've added this Google Account by "Gmail" not Microsoft Exchange.

  • Is that a public holiday calendar? If so, care to share the URL so we can better troubleshoot?
    – AllInOne
    Nov 13, 2012 at 22:29
  • Can you show us the calendar account settings (remove any personal information as necessary) on your iPad, as well as the settings in your Google Calendar account (i.e. any imported calendars, etc.)?
    – robmathers
    Nov 13, 2012 at 22:43
  • 1
    So try adding it as Exchange.
    – asmeurer
    Nov 14, 2012 at 8:31
  • @AllInOne It is the Google UK Holidays one - Calendar ID: en.uk#[email protected]
    – orange
    Nov 14, 2012 at 15:21

1 Answer 1


I've had this problem since back during the days of Mobile Me, worked with Apple on it by sending copies of my calendar, and even managed to get the problem to happen at their end via their website and without having my computer or devices involved.

Apple initially tried to pawn the problem off as Google's, though disabling Apple's cloud and using Google alone works perfectly.

In short, I don't think you're doing anything wrong. In the end, I had to have them completely delete the account on the Cloud, create a new one, and re-push everything back, starting with an empty calendar.

From my own experiments, the problem for me seemed to originate when a calendar event on Google spans more than one day (like over a weekend) is synchronized with Apple. It did not replicate calendars that didn't have these entries. Every time Apple synchronized, it seemed to add more calendar entries. My iPad produced warnings of horrific amounts (I have the screen shot around here somewhere), my Mac slowed to a crawl, eventually forcing me to have to disable the Cloud.

My notes are here:
1) http://www.wwco.com/~wls/blog/2009/07/25/mobileme-sync-problems-resolved/
2) http://www.wwco.com/~wls/blog/2012/06/23/resetting-mobilemess/

While I got my own problems sorted out, Apple's solution was pretty much (and I'm rephrasing here), "we're dumping Mobile Me soon, hopefully iCloud won't do it, and if it does, that's now another group's problem ...not ours."

On a Mac, the problem will eventually reach the point where iCal won't open. Here were my notes to Apple:

"Completely unable to open iCal without the spinning pinwheel of death, I put on my developer hat and did the following (though I have no idea how a mortal user would know how to do this):

$ cd ~/Library/Calendars
$ rm -rf Calendar\ [CS] *
$ du -h .
(find the largest file size entry and remove it, for example)
$ rm -rf 74D1E7F2-3CA2-44E8-9690-093227ACF17C.caldav

This lets iCal start, and during the upgrade process, there's barely enough time that if you're lucky you can open iCal preferences.

It gets worse. The console log goes wild with 500 messages per second. Meanwhile, Finder slows to a crawl and won't even handle right-click menus."

4/18/11 7:04:42 PM  [0x0-0x3d03d].com.apple.iCal[769]   line 1,1: expecting FREQUENCE, found 'INTERVAL' as token type 6
4/18/11 7:04:42 PM  [0x0-0x3d03d].com.apple.iCal[769]   line 1,1: expecting FREQUENCE, found 'INTERVAL' as token type 6
4/18/11 7:04:42 PM  [0x0-0x3d03d].com.apple.iCal[769]   line 1,1: expecting FREQUENCE, found 'INTERVAL' as token type 6
4/18/11 7:04:42 PM  [0x0-0x3d03d].com.apple.iCal[769]   line 1,1: expecting FREQUENCE, found 'INTERVAL' as token type 6
4/18/11 7:04:42 PM  [0x0-0x3d03d].com.apple.iCal[769]   *** process 769 exceeded 500 log message per second limit  -  remaining messages this second discarded ***
4/18/11 7:04:43 PM  [0x0-0x3d03d].com.apple.iCal[769]   line 1,1: expecting FREQUENCE, found 'INTERVAL' as token type 6
...hundreds of times...

To get anywhere, I had to use an outgoing firewall (LittleSnitch) and turn off connectivity to Apple.com -- things instantly sprang to life. If your Mac knows about the Apple cloud, then iCal will recreate files, even if you don't have an Apple cloud account configured in its preferences.

In looking at the log messages and examining the CalDAV, the most suspicious entry was this:


The ending date format looked off. I'd expected a YYYYMMDD, but have no idea what 020000 represented.

I'm hoping the above blog data gets you a bit closer in sorting things out. Again, I doubt its you.

If you're going to mess around with any of the raw file system, please, please, please make a backup. Noting that complete removing ~/Library/Calendars seems to solve things using the scorched earth methodology.

  • I appreciate the answer but my problem is to do with iPad Calendar not the Mac Calendar App.
    – orange
    Nov 19, 2012 at 17:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .