I've got a hard disk of 120GB (20GB free space). I'm a developer in XCode and sometimes I get the "low disk space error"-message that I can't even save my coded files before cleaning some of the space.
I don't know why this happens because without performing anything I'm losing about 19GB of space. This lost space regains if I restart the mac. I asked around with my friends, and they don't get this kind of behavior, so it seems I'm the only one.

I've tried MACKeeper Utility to clear unused things but it's only a temporary solution!
Does any of you have an idea what to do?

2 Answers 2


The issue is probably that the space is being taken up by swap files and possibly a hibernate sleep image. To see this do an ls -l /var/vm These files are deleted on a reboot and start increasing as you use more memory and Xcode takes a lot of memory.

You need to reduce the space used by the rest of the system. apps and data. Basically 120GB is too small unless you only use it for development and not any music or other media files. You can save a bit of disc space by removing unused applications and clearing out other languages (see other questions here) but getting a bigger or external hard disk is probably a better use of your time.

To see where the space goes see the applications in this question or from the command line du.

  • Spot on, this is almost certainly caused by swapping. I'll point out that one of the few improvements in Mountain Lion over Lion is that the dynamic pager has apparently been fixed to not generate such huge swap files. So if the OP is running Lion, an upgrade to Mountain Lion might not be a bad idea.
    – pmdj
    Nov 12, 2012 at 10:23
  • @pmjordan - can you provide a source for that information
    – mmmmmm
    Nov 19, 2012 at 17:49

@Mark is right about it being caused by extremely large swap files -- but you don't need a new disk really. It is a problem from within Xcode. If the swap files have gotten over 60 GB then just quit and restart Xcode. It will start over again at 0.

It seems to me that it is the indexing and autocomplete that is causing the problem, so if you can afford to code this way, just turn off autocomplete by going Preferences / Text Editing / Code completion: (uncheck all).

That much swap disk should not be used by Xcode. If the problem happens consistently, try submitting a bug report.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .