13

I have a thunderbolt to ethernet cable on a MacBookPro Retina on Lion.

Sometimes the thunderbolt to ethernet connection does not work. It seems to occur when I switch network locations (e.g., I move from my home network to my work network). Restarting the computer fixes the problem, however, I don't want to have to restart my computer.

How can I force thunderbolt to ethernet to connect without restarting the computer?

More details:

Under network settings, there is a red dot and not connected on "Thund...thernet". It further says:

Status: Cable Unplugged
Either the cable for Thunderbolt Ethernet is 
not plugged in or the device at the other end 
is not responding.

Under system information - thunderbolt it states

Thunderbolt to Gigabit Ethernet Adapter:

  Vendor Name:  Apple, Inc.
  Device Name:  Thunderbolt to Gigabit Ethernet Adapter
  Vendor ID:    0x1
  Device ID:    0x8003
  Device Revision:  0x1
  Route String: 3
  Firmware Version: 5.5
  Port:
  Status:   Connected
  Link Status:  2
  Port Micro Firmware Version:  0.0.8

Under Network - Thunderbolt Ethernet it states:

Thunderbolt Ethernet:

  Type: Ethernet
  Hardware: Ethernet
  BSD Device Name:  en1
  IPv4:
  Configuration Method: DHCP
  IPv6:
  Configuration Method: Automatic
  Proxies:
  Exceptions List:  *.local, 169.254/16
  FTP Passive Mode: Yes
  Service Order:    0
10

I had this problem, too, and an Apple Support call and Genius Bar visit later, I had the answer: if you're using Network Locations that preexist your Thunderbolt display, it doesn't seem to auto-add the possibility of "Display Ethernet" to your available network ports. To solve this, either:

Create a new Location in your Network system preferences. It will finally detect the "Display Ethernet" and use it. It'll slowly change from disconnected to No IP to green-is-for-go.

or

Fix an existing Location by clicking the + to add a port and choosing Display Ethernet. It'll slowly change from disconnected to No IP to green-is-for-go.

5

Workaround that worked a few times for me:

  • unplug the thunderbolt converter
  • Wait few secs, ten plug it back in
  • Go to Settings/Network/advanced/refresh DHCP lease
  • 2
    Hitting the "Renew DHCP Lease" button in the advanced settings -> TCP/IP of my adapter solved my problem. Thanks for sharing this solution! – KyleFarris Jun 23 '15 at 1:27
  • Voila! It worked! – uneq95 Feb 26 at 7:24
3

It seems like this issue at least for me may have had nothing to do with the thunderbolt connection. Rather it was a more mundane networking issue. I.e., when I moved between networks, network settings needed to be reconfigured. Techniques like renewing DHCP lease and using the "assist me" procedure in network preferences seemed to be sufficient for me to reconnect using Ethernet after switching networks.

2

Had this same problem, and unplugging/replugging didn't work.

In the end, restarting with the cable unplugged, and then plugging back in, worked.

Not at all clear why, but before I did that, no Thunderbolt devices were showing up at all in System Report even when the cable was plugged in.

  • I had to delete the existing interface, restart, login with an Admin account and then plug it in and it worked. Logging in with a regular account and using an admin password in the System Preferences was insufficient. Madness. – Peter N Lewis Mar 21 '18 at 5:40
1

Same problem here. IMHO it's a bug in OSX. Unplugging/plugging kicks something in the OS and then it comes back to live.

  • Only reboot Mac OSX solve this (osx bug). Uplink is active and "cable unpluged" appear. I'd done multiple plug/unplug withut success.Also sudo ifcfg not recognize thunderbolt ethernet. – myset Nov 1 '16 at 15:14
0

Same problem in Yosemite on a MacBook Pro with two Thunderbolt ports. Mac OS X seems to believe that the Thunderbolt ethernet adapter is really another Thunderbolt bridge because I see two Thunderbolt bridges. The solutions suggested are vague and clumsy, but lacking a command line solution there is only unplugging (like above), replugging, then adding an ethernet to an existing location without the wifi adapter in it.

The actual problem seems to be caused by a wifi connection becoming active and precluding the ethernet connection. The best and most permanent fix I have found is to turn off wifi before arriving at the office. Then plugging in the ethernet always works. But if I allow that wifi connection to become active first, then plugging in the ethernet quite often fails.

0

There is another problem related to this. Often when I unplug the thunderbolt-ethernet connector from the mac's thunderbolt port, my thunderbolt (display port) DISPLAY connected to the other thunderbolt slot goes black. No "no signal" but just a black screen. The computer does not crash, sometimes I hear audio continue to play for instance.

Plugging back the ethernet connector then sometimes restores the display but the ethernet is still broken then. If I also unplug the display then the computer (which is in clamshell mode) seems to hang up instead of going to sleep. I can hear the fans running. It takes about 5 minutes before the laptop then finally goes to sleep. Sometimes opening the laptop then helps out. Other times, I need a hard shutdown.

To me this problem seems not related to WiFi as I always have it off. (but maybe the system tries to turn it on and fails on that?)

From this correlation between the display and the ethernet, it seems the real problem is in the thunderbolt driver, not in the ethernet.

Sorry that this is no workaround but maybe it gives some new suggestions to work around this

  • Welcome to Ask Different! Please refrain from adding comments in the Answer section, this is for answers to the questions. Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. Flagging for removal as not an answer. - From Review – fsb Sep 26 '16 at 19:56
0

None of the above solutions worked for me, but one from https://rohanradio.com/blog/2012/02/27/fixing-thunderbolt-ethernet-on-the-macbook-pro/ did:

  1. sudo rm /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
  2. Unplug the Thunderbolt Display
  3. Restart
  4. Plug the display back in

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .