8

on my Mac 10.6 (MacBook Pro Late 2009) master volume control for both Line-In built and for external USB Microphone is disabled (grayed out)

master volume control Nobody really wanted to help what is the reason and how to bring back such behaviour. Googling didnt provide answer.

What I want is to have master volume slider active at least in Blue Yeti microphone. Any help?

  • Hi, and welcome to AskDifferent! Could you add a bit more information about the exact model of your Mac, and what it is that you are trying to do? It will be easier to help you then. You can edit the info directly into your question. – myhd Nov 7 '12 at 11:11
  • 1
    I edited question :) – Sebastian Nov 8 '12 at 16:34
12

I ran into issues where my audio controls were disabled similar to what you describe. I can't be sure it's the same issue, but in my case, killing the Core Audio process fixed it.

Open up Terminal and enter this command:

sudo kill -9 `ps ax | grep 'coreaudio[a-z]' | awk '{print $1}'`

You'll be prompted to enter your password, but that should find and kill the proper process, which will then auto-restart. Your volume control should come back to normal within a few seconds if this is indeed the problem.

  • 1
    I did this but it didnt work. Audio controls are ok exept master slider volume in Adio-Midi congiruation setup app. – Sebastian Nov 8 '12 at 0:56
  • 2
    Worked for me! Good work! Shouldn't need [a-z] in there. Always 'd' since it's a daemon. sudo kill -9 `ps ax | grep 'coreaudiod' | awk '{print $1}'` – GusOst May 14 '14 at 15:15
3

With some digital audio input devices, by design, it is not possible to adjust the volume level within System Preferences, Audio MIDI Setup, or GarageBand or the like. The volume level can only be adjusted on the external digital audio device.

I suggest that you contact the technical support staff at Blue Microphones, the company that makes your microphone, to ask them about this.

  • This answer needs more up votes, it's the correct answer. Not all third party devices provide master volume support. – Ian C. Sep 29 '14 at 1:18
  • @IanC., his problem existed both with AND without the Blue Yeti connected. As such, this answer is incomplete and not entirely relevant to the OP's question. – Trane Francks Sep 29 '14 at 1:44
  • @TraneFrancks none of that is stated in the question. In fact, his question says "What I want is to have master volume slider active at least in Blue Yeti microphone. Any help?" -- this is the question, above is the answer. Full stop. – Ian C. Sep 29 '14 at 1:47
  • Sebastian wrote this on Nov 8 in answer to Robert Wilson above: "As you see the main master volume is grayed out and slided to the left. The same is when I attach blue yeti external usb microphone." – Trane Francks Sep 29 '14 at 2:30
2

You could check System Preferences > Sound > Input and make sure it is set to the correct audio device.

Without more information it's difficult to offer much more advice than that.

  • Hello I attached screenshote here. As you see the main master volume is grayed out and slided to the left. The same is when I attach blue yeti external usb microphone. It is definitely not normal behaviour because several other people said that on their computers sliders are ok. because master volume is disabled I cannot increase gain on yeti which results in low output during recording. Google gave no idea , as well as no other sound forum or such (wtf). – Sebastian Nov 8 '12 at 0:56
  • Hmm... it looks very similar to my settings in Apllications > Utilities > Audio MIDI setup > Built In input. My master volume is inactive too. what exactly are you trying to achieve that would require this slider to be enabled? From reading your original post, it looked as though you wanted to control the gain on the USB microphone. If so, you would probably be better controlling it via audio software such as Logic / Garageband. – Robert Wilson Nov 9 '12 at 13:17
  • Unfortunately there is no more margin left to control this in GarageBand. Look at this movie on YT: youtube.com/watch?v=9F57zYjOwq8 there is clearly master volume not-grayed out for this guy. – Sebastian Dec 5 '12 at 19:12
0

Looks at the microphone input jack and see if it's glowing red. If it is then your computer thinks a microphone is plugged into it. Fiddle with an aux input putting it in and taking it out at different speeds. This should resolve the issue (if only temporarily).

0

I have found in later (2013) vintage Macbook Air's that the headphone jack no longer works as a line-in. I ended up buying a cheap USB minijack adapter for this. Although it's a touch temperamental, it does do the trick for recording audio in.

0

If you are using a device that does not support volume control, such as the DAC I plugged in and showed up as "HD USB Audio", you can work around the issue by using SoundFlower. Install SoundFlower, set "Soundflower (2ch)" as your output device, start up Soundflowerbed, from the menu icon set the 2ch Soundflower device to forward to your "HD USB Audio" (or whatever your device is called). Now, Soundflower should be able to software-control the volume before forwarding the signal to your hardware. Good luck!

-1

Volume sliders If software volume control is available for your device, the Volume sliders are blue to indicate they are active. Drag the sliders to set the volume for each channel.

  • Welcome to AskDifferent! We prefer answers that are high quality and in-depth. Would you mind editing this answer to provide more details on how the OP can fix the problem? – bassplayer7 Jan 30 '13 at 13:51
-1

Just resolved this issue on OS X Mavericks. I'm not sure how it started on my computer to begin with. I went to Audio MIDI Setup. Then in the Audio Devices I went to Built-In Output. Then where it says "2ch-24bit Integer" I selected "2ch-16bit Integer". After that I was able to change the volume and the volume icon wasn't greyed out. You can then change it back to "2ch-24bit Integer" once you get the volume working again.

  • Question is about input not output – Mark Feb 21 '15 at 18:01

You must log in to answer this question.

protected by bmike May 31 '17 at 11:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .