As I understand it, active Apple Mail rules automatically get applied when mail comes into the Inbox.

Is there a way to prevent rules from being applied automatically, so that they are only applied when I click the "Apply Rules" menu item (or use the shortcut, cmd-option-L)?

3 Answers 3


Actually, when a rule is not Active, it is never applied, even when one manually selects Apply Rules... too bad, I want to do exactly that for years now, and it is still not working, the only way to implement rules is to have them applied automatically when the message enters.


Apple Mail rules run automatically only the first time they're set. After that rules will only run manually.

Going into Preferences and unchecking 'Active' will deactivate the rule and will never run it.

  • 1
    not sure what this says that hasn't been said already… 2 years ago
    – Tetsujin
    Commented Jun 30, 2015 at 12:47
  • This is not the case anymore. With MacOS Catalina, Big Sur, Ventura (and probably other versions), the rules are completely disabled when not "Active". So it's impossible to trigger them manually!
    – 118218
    Commented Feb 1, 2023 at 14:25

In Apple Mail, go into the Preferences and uncheck the "Active" box next to your rules. Then they won't be run automatically. They will be run if you manually select Apply Rules.

If you want some rules to run automatically and others only to be manual, you need to do a couple of extra steps. First, move your manual-only rules to the top of your list of rules, because rules are applied in the order that they're displayed in that list. Then, in your manual-only rules, make sure that the last item under "perform these actions" is "stop evaluating rules.

  • 3
    actually, running MacOS 10.10 and newer, it is not true. If a rule is not "activated" it won't be run either automatically or manually by cmd-option-L or by right clicking "Apply Rule".
    – Jan
    Commented Feb 11, 2017 at 10:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .