I'm the developer of an application that is currently on the Mac App Store. I'm trying to download my own application so that I can test out the binary that is on the store. (As opposed to running it in Xcode.)

I have purchased my own app in the app store previously, but then deleted it. (So that I could install a different version for testing.) Now, the App Store thinks that the application is still installed, even though it is not. (I deleted the development version when I was finished using it.)

I have removed all instances of the application from:

  • /Applications
  • ~/Downloads

But the app is marked as "Installed" in the App Store, and it doesn't show up in my purchases. Is there a trick to get my binary re-installed?

  • As said below, don't forget to accept your own answer as it's the solution to your question! – LudoMC Jan 28 '11 at 12:52
up vote 44 down vote accepted

Awesome, I figured it out. Run this command, which rebuilds LaunchServices:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

And everything should be back to good! Immediately after running, the App Store allowed me to re-purchase the app.

Source: MacLife Link

  • Well then, mark that as answered! – Christian L Jan 28 '11 at 2:51
  • I'm trying to reinstall Xcode, but this doesn't work. – neoneye Nov 4 '11 at 21:29
  • Nice find, works great! – sudo rm -rf Feb 20 '12 at 1:45
  • This didn't help me, I'm still unable to reinstall some applications. :/ what would I do? – entropid Feb 21 '12 at 2:49
  • 2
    Sorry @jessica - things may have changed since I ran this, which was for 10.6. – Craig Otis May 29 '16 at 10:27

Just hit Launchpad and delete your app there by clicking and holding down the mouse button and clicking the "x" top left.

Now the Mac App Store knows it's deleted. Just redownload and be HAPPY!

  • Just make sure you've upgraded to Lion and you're good to go :-) The original question was asked last January, so there was no Launchpad present. – Jari Keinänen Oct 25 '11 at 8:10
  • Mavericks - even though I deleted and emptied the trash, the item was still in launchpad. Deleting it there let me re-download. Thanks! – Dave Martorana Jun 2 '14 at 20:22
  • 1
    Works where the other didn't. – user1122069 Nov 9 '15 at 21:31

It could be that the App Store interface sees your development version(s) as the installed copy. LaunchServices doesn't care if your app is in the /Applications folder or buried in your Xcode build directory. See also.

  • Nope, no references to the app anywhere. I deleted the contents of all the intermediate build directories. The app is gone for sure. – Craig Otis Jan 28 '11 at 1:08

On Snow Leopard, I not only had to run the command in Craig's answer, I also had to make sure that Spotlight was up to date and did not show the app in question to still be on the computer.

You can refresh particular folders in Spotlight's index using the mdimport command. So to refresh the /Applications folder:

mdimport /Applications

I had a Lion partition as well as a SL partition on the machine. Spotlight was set up to index everything on both partitions, and there was a version of the app in question on my Lion partition. I added the entire Lion partition to Spotlight's ignore list, then ran the command in @Craig's answer, and everything worked. Just running the command in @Craig's answer was not enough for me.

Nothing helped (El Captain), so I opened Launchpad (F4), found application there, dragged it to Trash and successfully reinstalled.

Had the same issue. Just restarted my mac and then the app store could see that the app was not installed.

You can also hold down option while clicking the app in the app store to force it to re-install.

This will work on OSX Mavericks and Yosemite.

Instead of launching the App Store app from the dock or the apps folder, launch the App Store app from within the Launcher. This will rebuild the App Store app and tell you what's installed or not.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.