Ever since installing iOS 6.0.1, it appears that all my Google Calendar events appear as invitations. Is this happening to anyone else? Is there any way for me to fix this?

The only events that don't appear as invitations are the ones in my main calendar; I've got three calendars, one for personal, one for work, and one for other, and only those in personal are fine. The events in the other two calendars appear as invitations in my Calendar app on my iPod Touch.

  • Same problem here since update to 6.0.1. also change all entries to invitations and unable to edit.
    – user34081
    Nov 4, 2012 at 15:46

1 Answer 1


This appears to be an issue when Google is set up as a Microsoft Exchange account type (Google Sync) rather than the normal Gmail account in the Settings app. You can check that this is the case for you by opening the Settings app, going to the Mail, Contacts, Calendars section, and tapping on your Google account. If you see Exchange at the top of the page - rather than Gmail - then this applies to you.

It seems that in fixing an Exchange bug Apple broke Google's Microsoft Exchange implementation.

It also seems only to be a problem with secondary accounts.

As a temporary measure – until either Apple or Google have fixed this problem – you could open the Settings app, go to the Mail, Contacts, Calendars page, and Add Account... of type Gmail. You only have to turn on Calendars for this account, as the rest of the Microsoft Exchange implementation seems to be working. Then go to your original Microsoft Exchange account and turn off Calendars. You will be warned that all your Exchange ActiveSync calendars will be removed from your phone; choose to delete them. Finally, you might want to adjust the Default Calendar in the Calendars section of the Mail, Contacts, Calendars settings page

A few caveats with using a Gmail type account for calendars:

  1. Google event invitations will no longer work
  2. Syncing for calendars is now pull, rather than push; i.e. changing an event on another device will not be reflected immediately in your iOS calendars

Also, beware that events you have declined will not appear in iOS, and you may have accidentally declined events while getting frustrated at the iOS 6.0.1 calendar problem. These you will need to fix in the Gmail Web Client.

  • Hello, and welcome to Ask Different! This site is trying to be the definitive, community grown Q&A on all technology Apple. Your answer would be more helpful to the OP, as well as for future visitors, if it included details on how this is done. Also, questions should be confined to comments, and some kind of documentation providing context would distinguish your answer from a simple “try his” suggestion, which also belongs into comments. Thanks for pitching in, and enjoy the site!
    – kopischke
    Nov 4, 2012 at 21:59
  • @kopischke I have explained exactly the problem, and given instructions for a work-around; is this better? Nov 11, 2012 at 6:48
  • Much better – in fact, your answer is now exemplary. Congratulations, and glad to have you around!
    – kopischke
    Nov 11, 2012 at 17:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .