2

I have a Mac OSX Lion file share over the AFP protocol in our office and users are having trouble saving to it. Here's the process:

  1. Open an existing file on the server
  2. Make changes
  3. Save changes, error: "The document “X” could not be autosaved. You don’t have permission."

Additional notes:

Users cannot save new files directly to the server (same permissions error); however, they can save the file to their desktop first and then drag it to the server in the same location.

Here is a print out of the permissions for that particular directory:

enter image description here

The permissions appear to be wide open...right?

For what it's worth, here is a screenshot of the error:

enter image description here

Any ideas what I can do to resolve this issue?

  • Are there any flags on the directory, and what xattrs does it have? Try ls -leO@d (and be sure to run that on the server, not a client). – Gordon Davisson Nov 4 '12 at 6:19
1

Which place do you have users created on the server? Are they here: enter image description here

Or are they here: enter image description here

The important question is are they local users (which will give you the behavior you have) or are they local NETWORK users?

  • Thanks for your answer. They are created in server.app, but mine looks slightly different than yours. Remember, I'm on 10.7 server: cl.ly/image/003A3u1Z3M2F – Jesse Bunch Nov 3 '12 at 23:12
  • It's all I had to screen shot, sorry. Is only one person opening a file at a time? Or are three or four (multiple users) opening the same file? – Everett Nov 3 '12 at 23:17
  • I've tried it in both scenarios. Same issue. – Jesse Bunch Nov 3 '12 at 23:43
  • I tried, sorry to have wasted your time. At least you know something it's not. – Everett Nov 4 '12 at 6:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .