In this question, I learned that the "dotted-line cloud" icon in OS X's iCloud file view means "Waiting to upload". While writing a document in Byword today, I saved it and found it had been marked with this icon - there were several other documents, months old, that still had the "Waiting" icon as well.

Is there any way to, if not force, gently encourage these files to upload to iCloud?

  • 2
    The gently encourage part is so Apple :) I was wondering if there would be a better solution now in 2017. But apparently not. Commented Aug 22, 2017 at 13:47
  • It appears that attempting to download them from iCloud on another computer will cause the computer that actually has them to upload them (assuming the host is also connected at that time)
    – iconoclast
    Commented Oct 4, 2017 at 3:09
  • In my case, I was trying to upload a file to icloud via an iPhone, and it got stuck in the message "waiting to upload". But later, as soon as I turned on the Wifi in my home, it started uploading immediately!... it was nice, it didn't want to burden my cell phone bill :-)
    – Alexandre
    Commented Dec 31, 2017 at 20:38
  • 3
    Still crap in 2020 Commented Jun 11, 2020 at 15:54
  • 1
    Still crap 2023
    – cuzzea
    Commented Jul 2, 2023 at 7:53

15 Answers 15


In the terminal touch the file and it is fixed.

  • This is probably the least-"destructive" way to nudge iCloud into re-syncing a file (I would imagine—haven't tested it), since touch just changes file metadata (the modification and access times). I like that better than making a change to the file's name or actual contents and then reverting that change!
    – Dan J
    Commented Feb 2, 2020 at 2:22
  • 1
    Doesn't work any better than trying to rename, make a slight change etcetera. Sometimes it work, sometimes not. Just depends if it's your lucky day or not. Commented Oct 16, 2020 at 18:47
  • Worked for me..
    – d-b
    Commented Oct 17, 2020 at 20:53
  • 1
    A simple touch updated my macOS finder from the "dotted line" icon to the solid line icon. Smooth trick.
    – Urda
    Commented Jun 15, 2021 at 17:48

I was concerned I'd have to save these documents to my local filesystem, delete them from iCloud, and then perhaps save them to iCloud over again, but it turned out that simply re-opening the "Waiting" documents, making a trivial change to them (such as deleting a character and then adding it in again), and then saving the file caused them to be synced successfully.


It seems like the issue is the iCloud daemon hanging. The following command kills that process which causes the OS to restart it. That seems to work in many cases and doesn't require deleting or recreating files.

ps -ef | grep -i 'Support/bird' | grep -v grep | awk '{ print "kill -9 " $2}'|zsh
  • 2
    Please explain what this is doing and why it works
    – mmmmmm
    Commented Dec 27, 2021 at 21:31
  • 4
    Nice find about killing a stuck daemon. Shorter versions are pkill -f 'Support/bird' (or, if you are on an old version of macOS, kill $(ps -ef | awk '/Support\/bird/ { print $2}')).
    – nohillside
    Commented Dec 28, 2021 at 8:03
  • Worked on OSX Monterey
    – Rescribet
    Commented Apr 13, 2022 at 9:48
  • Worked for me without force-killing it too (i.e. kill without the -9 argument), which lets the daemon shut down properly. I just searched for bird in Activity Monitor and selected "Quit".
    – Frederik
    Commented Apr 4 at 18:45
  • Worked on Mac Sonoma (14.4.1) without -9 as well. Commented Apr 24 at 21:36

I just had success by renaming the file (added a space to the end)


Log off or restart the system. This worked for me on Macbook.

  • 1
    this is the only solution that worked for me. Thanks.
    – Duck
    Commented Apr 6, 2023 at 7:48

I ran into a similar problem but every time I tried to open the file, the hosting application (Keynote in this case) hung. I was able to killall -9 ubd to unwedge iCloud.

  • 1
    No matching processes were found
    – iconoclast
    Commented Dec 28, 2017 at 4:45
  • 2
    Yes, this was a nearly 4 year old response. ubd no longer exists on current macOS versions. Commented Dec 30, 2017 at 14:50
  • What is the current alternative? Do you know of any? (And I'm on 10.11.6 anyway—originally to maintain the use of Karabiner, and later because the hassle of recreating my Karabiner config in Karabiner Elements outweighs any obvious benefits of upgrading.)
    – iconoclast
    Commented Jan 3, 2018 at 22:19

I had to shut down and restart my iPad Pro in order to get the PSD file I was trying to upload to finally stop “waiting to upload” and just do it already.


What solved the problem for me was signing off iCloud account and removing the data from all the devices assigned to my account and then signing back in. After doing so on all of my devices (two iMacs and iPhone) and signing back in, syncing worked as it should in iCloud Drive and in Notability.


On the Mac I simply used the Compress command to create a .zip file of the missing file. In one case this was enough to trigger the refresh.

In other cases I had to unzip the compressed file and then check the contents. Once confirmed they were correct I just deleted the original file and the .zip file. I then renamed the uncompressed one that just had a 2 added to the name and everything was fine.


The way I fixed it was to drag one document over another, which automatically creates a folder (like in iOS). Then, I dragged them back out from the folder, and the status waiting status was gone.

  • This does absolutely nothing for me.
    – iconoclast
    Commented Dec 28, 2017 at 4:46

The way I fixed “waiting” was to drag one document over another while holding down “option” key.

  • Besides copying one of the files, this changed the status message under the file to "Uploading" for several seconds, but it reverted back to "Waiting to upload"... and then to "Uploading", and back to "Waiting to upload".... 😱
    – iconoclast
    Commented Dec 28, 2017 at 4:43

When I first experienced this problem I tried clicking on the icloud download icon and I received the "waiting" message after about five minutes. However, I checked inside the folder and noticed that other documents also had the "waiting" message. I navigated to the upper level folder and clicked icloud icon of the folder with my "waiting" documents inside. It took about 35 minute and I never navigated away, but all the documents marked as "waiting" eventually downloaded.


If you trying to upload files over mobile data make sure you change icloud settings to allow for sync over mobile data and then try restarting your phone.

I added a document to my files, then changed my icloud setting (which I should've done before trying to upload them) then I found I had to restart my phone before the files actually uploaded to icloud.


I realize this is an old thread but was having this issue recently with macOS Ventura 13.5.2, and this thread was in the top of Google's results.

Opening files/folders didn't make a difference. I opened Activity Monitor and located the Bird service, which is the CloudDocsDaemon, and killed it. macOS re-launched it automatically and instantly, and all my pending files uploaded right away.

  • While it is your personal experience, it is essentially the same as pcvnes' answer. Is there anything that makes it unique or different?
    – agarza
    Commented Sep 21, 2023 at 3:36
  • @agarza Providing a terminal command without explanation has the potential to cause more damage then anything else. My answer provides an alternative by using the existing utility included in macOS with an explanation, for those who don't feel comfortable copying/pasting random commands in terminal. Commented Sep 21, 2023 at 4:09
  1. 2-finger-click the song.

  2. Select "Add song to iCloud music library".

  • 1
    How does this help to upload stuck files into iCloud?
    – nohillside
    Commented Jan 22, 2016 at 19:51
  • We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.
    – Tetsujin
    Commented Jan 23, 2016 at 8:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .