1

I'm trying to set up our server so that file permissions make sense. We have a mac mini running OSX 10.6.7. Through our desktop Macs, we connect to shared folders on that server and save files on it, in Finder, TextEdit, etc.

I've set up a umask, as documented here. However, this only works from terminal/finder directly on the server. If I save a file to the server using a connected desktop, it doesn't work.

Any ideas on how I can resolve this?

1

umask is a user- and process-specific setting and can be overridden. Setting a umask on the server does not affect any clients that accessing the shared folder - each of them will use their own default file creation permissions.

If you want to set default permissions on a shared folder, the answer is to use Access Control Lists (ACLs), which are much more flexible.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .