I have a MacBook Pro 13" and my wifi connection never works properly. I know there are no problems either in the MacBook or in the router since:

  1. Another computer can connect to my router easily
  2. I connected my MacBook to other routers

My router is a Linksys WRT160NL that seems to work properly since also my iPhone can connect to it.

When I go to the Airport icon on the top-right of the screen, I can see my router. I click on it and wait. A dialog box appears asking me for the password. I type it in (I'm sure I'm typing it right and that it is a WPA password, I guess it is the same of WPA-Personal), the progress bar (the circle one) keeps rotating for about 5 seconds then stops and got replaced by an Annoying-useless-freaking message saying:

Connection Timeout

I googled about this problem. I found some useless thread about this exact problem but they were so old that they date back to the first appearance of Leopard. The others say that this bug was fixed (when obviously it is not) thousands of versions ago.

What should I do to fix this?

  • do you try to create new Location in Network Preferences? – Am1rr3zA Jan 26 '11 at 20:39
  • I have searched for this problem too, but you may have to give as much information as possible because the number of reasons for a macbook not working on wpa on linksys routers are endless. Do you put your macbook to sleep ? What version of Leopard is it ? How is the DHCP working ? Could someone be bumping you from the network (I don't know if this is how deauth attacks works) How far is the router from the macbook most times? – phwd Jan 26 '11 at 23:10

There are LOTS of reasons for this not to work properly. First of all - don't rule out the router or the Macbook yet. They are both suspect until ruled out methodically. And we're far from ruling either of them out. :)

Are you sure it's WPA-Personal? It could be WPA2. Check the router settings themselves, by plugging in to the router, and connecting to its web interface. Check again. Check the password. Check if it's AES or TKIP. Once you're sure you know as much about the router and its wireless config as possible, try again, after unplugging your wired connection to it.

In System Preferences, remove the network if it's remembered. You'll need to go to Network, Airport, Advanced, and then find it in the list, and hit the little minus. Now try connecting. I've seen networks that were set to WPA2 come up as WPA-Personal, since the laptop sometimes has trouble figuring it out.

For these, I've had to set them up manually, by going into the system preferences, network, airport, advanced. Add a new network (plus at the bottom), put in the name EXACTLY, and the password, and WPA2-Personal.

Failing this, check if your router's using a "key index". If the index or key index is NOT set to 1, the macbook will fail to connect. I've never found a way to force a Mac to use a different key index, and indeed some routers allow you to choose which index you'd like to use. If the router's key index is not set to 1, your macbook will not be able to connect, period.

Failing that, reset the router and set it up again, using WEP rather than WPA/WPA2. Can it connect now?

Try a different Macbook, or try a PC. Can it connect?

Answer these questions in as much detail and I can help you more. Don't give up.

  • 1 - It's WPA or WPA-Personal, anyway i tried changing it from both Macbook and Router configuration and try both and it didn't work. 2 - Tried to remove the network from the preferences and it didn't work. – Shoe Jan 27 '11 at 18:23
  • 3 - I cannot find this 'index' or 'key index' you are talking about. Where is it? 4 - Using WEP it doesn't connect. 4 - Another Macbook can connect to it. – Shoe Jan 27 '11 at 18:32
  • @Charlie the index can't be changed on some routers. If yours is one of those, then let's not focus on that, because it's not the problem. You said another Mac has connected to your network before. Get that Mac, go into System Preferences, Network, Airport, Advanced. Open up your wireless profile. Make sure the settings are your Macbook are exactly the same. – Harv Jan 28 '11 at 0:43
  • I did tried to set wpa-2 as password again, due to my depression, and it didn't work the first time. Then i rebooter my Macbook and now it seems to be working well. It's strange because i've already tried it like a week ago and it didn't worked. Anyway thanks very much. – Shoe Jan 28 '11 at 12:05
  • @Charlie Pigarelli - glad I could help. – Harv Jan 29 '11 at 22:29

Switching the channels fixed this problem for me.

  • My router was set to use "automatic" channel. After changing it to use channel 1, it started working. – Frank Schwieterman Oct 31 '14 at 23:39

One solution that works fine is this one http://osxdaily.com/2011/11/06/lion-wi-fi-problems-solution-mac

Short story : Add a new location under the wifi network preferences


I had the same problem for my iMac when upgrading to Moutain Lion. I could not connect to the internet anymore. What I finally did is change the channel in your router. If too many people are on the same channel you can get this connection timeout issue. You should have multiple channels you can choose from in your router.

Good luck!


Funny I had the same problem after updating to my OSX (Macbook Pro 13") and kept having the same issues over and over again to no luck... then I plugged in my computer to the router via CAT5 cable... connected to the net.... and tried the wifi again... and it worked. Weird.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .