I have an iPhone 4 loaded with unmodified iOS 6. I use it (for two years now) with a virtualbox running Windows XP with iTunes (10.7 currently).

Everything works just peachy most of the time, and when it doesn't I can usually find the fault and correct it quickly.

Earlier today I was synchronizing my iPhone, and it seemed to have worked fine, or so I thought. I wanted to re-synchronize after updating an app via iTunes, and suddenly the software tells me it cannot read my iPhone and that I must restore it to factory settings before I can use it again.

My last backup was two weeks ago, and I fear that deleting it would mean that I cannot restore any data if I end up resetting the phone.

What I already tried:

  1. I checked the iTunes and the cable with my girlfriend's iPod Nano. Everything works great.
  2. I tried to reboot my virtual machine.
  3. I tried to reboot my iPhone.
  4. I tried to reboot my virtual machine after rebooting my iPhone.
  5. I tried to see if there are any "bad" files somewhere that I may delete, some incomplete transfers or so.
  6. I tried to meddle within the log files, but I wasn't sure which ones to check or what to do.

The iPhone works perfectly fine, by the way.

Please help me.

What should I do to correct this, and if I do end up restoring factory settings what happens to all the texts/photos/music/etc. I have on my iPhone right now?

(I have a traumatic experience from the upgrade to iOS 6...)

Edit: Quite some time later, my iTunes still insists that I need to restore my phone. I tried to delete all the previous backups and remove iTunes and whatnot, but nothing helped. I tried to connect it to other iTunes and they all tell me the same thing: I must restore the phone to factory settings.

However, being a "cunning" Linux user I decided that I should try and see if I can access the phone from the Linux part of the computer, and indeed I can. Being able to browse through the files it hit me that it might be possible to fix the problem through manual tempering with some file (or removing some leftover files).

Is it possible to do that at all? If so, is there a guide or some hint on how to find out what needs to be corrected?

  • I have been having the same problem for days now. I thought it might be a storage issue. Even after deleting all photos and downloaded apps it keeps happening. I have to carry a back up phone all the time. This is getting ridiculous. If you have found a solution, please post. – user56462 Sep 4 '13 at 18:41

Firstly I would sign up to iCloud if you haven't and then use the over the air backup to backup your iPhone (You get 5GB free!) then once this is done, you will be able to reset the phone should you want / need to.

Have there been any updates to your Virtual Box since your last sync? If not, it could be that iTunes can not see its XML file needed for device synchronisation; also ensure that all of the helper services are started on your machine.

Failing the above and assuming you follow the first recommendation, try resetting and restoring from iCloud.

Best of luck


Hi I had the same problem. I am using win 7 64 bit. I have installed MediaMonkey, the I connected iPhone to the PC and once the window popped-up, I clicked on "open with MediaMonkey". Than the phone was synced in MediaMonkey and after that in iTunes as well.


connect your iphone USB cable to the pc or mac with the iphoe still turned of, with iTunes running connect your phone to the USB cable but keep pressing the homw button untill a window pops up saying ur phone is on recovery mode and then, its gonna give u the option to restore ur phone. tht means it will delete EVERYTHING!!!!!!!!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .