I have a MacBook Pro, running 10.8.2. I'd like to give Windows 8 a go, using Boot Camp. Now, I've probably done a b Boot Camp install of Windows close to 10 times, on multiple Macs, but I'm stumped right now.

This computer previously had full disk encryption on, which I disabled last night.

Now, it seems as though a lot of the free space needs to be... defragmented.

Following are 3 screenshots, the first of Boot Camp, complaining of no free space, the second of all of my free space, and the last of the disk's partition map:

enter image description here

enter image description here

enter image description here

I Googled a bit, and have tried repairing the disk and permissions, and both found a few issues, but still the disk appears to be fragmented.

EDIT: For @pmjordan

Josh-Work-MacBook-Pro:~ josh.oneal$ diskutil list
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            250.1 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
Josh-Work-MacBook-Pro:~ josh.oneal$ sudo gpt -r show disk0
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  488555536      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  488965176    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  490234712          7         
  490234719         32         Sec GPT table
  490234751          1         Sec GPT header
  • 1
    Just to check that there are no leftovers from full disk encryption (CoreStorage) in your partition table, can you please post the output from these terminal commands: diskutil list and sudo gpt -r show disk0?
    – pmdj
    Oct 29, 2012 at 20:58
  • @pmjordan Any thoughts?
    – Josh
    Oct 30, 2012 at 14:20

1 Answer 1


Thanks for the update, your partition table looks fine.

One more thing to try would be to boot from the recovery system or installation media, or access the drive from another Mac via Target Disk mode and try to resize the partition from a Disk Utility instance that isn't booted off the partition you're trying to resize. Unfortunately, it's fairly unlikely this will help - I've seen more instances where it didn't than where it did.

If Disk Utility can't help you, the only solutions are:

  1. Back up, erase and restore

  2. Try your luck with something else. In the past, resizing via parted (an open source Linux utility) has worked for me in such cases. I'm writing this on a MacBook Air with an OSX installation that survived the procedure unharmed. There's a bootable Live CD/DVD distribution of this available, called "Parted Magic"; "GParted Live" is another, which seems to be a bit more user friendly. You can burn either to disc and boot into it by holding the option key during the boot chime, as usual. Then shrink your main partition - this will take a while, as it needs to move the data to free up the space at the end of the partition. There is of course a certain risk associated with this, so make sure you've backed up and are prepared to go through with option 1 instead. Make sure to unplug your backup disk during any such procedure. One issue with using another tool is that unlike Disk Utility or Boot Camp, this won't move the Recovery HD. So your best bet is usually to shrink by the required amount, then grow it again to the original size. Doing this will then "unstick" Boot Camp/Disk Utility, and they'll be able to proceed with the shrinking as normal.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .