2

I'm using OS X Mountain Lion 10.8.2, with Microsoft Office 14.2.4.

Problem: Ever since I installed new updates of OS X, Excel can no longer display the thousands separator.

How can I get it back?

5
  • Are you asking how to get it back, or just making the general observation? Commented Oct 29, 2012 at 4:39
  • I want to get it back
    – angry kiwi
    Commented Oct 29, 2012 at 6:44
  • 1
    The link to your video seems to have gone dead, maybe you can list out the steps to reproduce? I've tried using the same version of Excel, but on 10.7.5 and I can get a thousands separator the normal way, but going to cell format, selecting the number type and checking the box for thousands separator.
    – robmathers
    Commented Nov 22, 2012 at 3:30
  • @robmathers reuploaded the video
    – angry kiwi
    Commented Nov 24, 2012 at 17:13
  • As of today May 30,2013, using Excel 2011, and OS X (10.8.3) this solution is NOT working for me. Anyone else? I tried using other regions, custom separators, new files, nothing changes. No commas.
    – user50362
    Commented May 31, 2013 at 0:00

4 Answers 4

3
+100

A temporary workaround is always simply Command-A to select all cells and clicking this convenient button in the ribbon under the Home tab in the Number section:

enter image description here

A more permanent solution is as follows:

Go into System Preferences > Language and Text and click the "Region" tab. If the first region dropdown menu is United States (Computer), this might be your problem. Looking below shows that this region formats numbers without a thousands separator.

enter image description here

This appears to be the result, as you stated, of an OS X update. Instead, set the Region to United States (without the Computer part).

enter image description here

From the Excel Help window:

Display or hide the thousands separator

Select the cells that you want to adjust. On the Home tab, under Number, click Display the value of a cell with a thousands separator.

Note: Excel uses the Mac OS system separator for thousands. You can specify a different system separator by changing the regional settings in Mac OS X International system preferences.

We have just done that, but it appears that Excel continues to ignore the change. Re-install Office and update us with the results.

6
  • look like you using a different version of excel. mine is 14.2.4
    – angry kiwi
    Commented Nov 24, 2012 at 17:11
  • @runrunforest which screenshot are you referring to? mine is 14.2.5 - can't be too different as they're both from the 2011 suite.
    – Ethan Lee
    Commented Nov 24, 2012 at 18:42
  • @runrunforest According to your video, you should have the first screenshot; I saw it in the home tab (it looks like a comma). As for the second and third screenshots, that's in System Preferences under Language and Text.
    – Ethan Lee
    Commented Nov 25, 2012 at 1:38
  • I now i understand. it has nothing to do with excel. the region setting is affecting excel. I changed to your suggestion thing is now back to normal.
    – angry kiwi
    Commented Nov 25, 2012 at 2:02
  • @runrunforest glad I could help! no rush- but you still have an active bounty. are you looking for anything else, because I can try to address any more questions you may have (about excel, region prefs, etc)
    – Ethan Lee
    Commented Nov 25, 2012 at 4:12
0

Formatting palette Number Custom Edit format of the prototype number (I removed the dollar sign, but kept the commas)

I have Mountain Lion and Excel 2008 for mac

0

Setting the System Region Setting from 'United States (Computer)' to 'United States' worked for me!

Running Mavericks 10.9.5 and Office 14.4.5.

0

I had the same problem and just applied the solution recommended, to change the region from US Computer to US, and know what? It worked! But don't forget to close Excel and open it again to see the result.

1
  • Flagging this to be closed as a 'me too' post and not an answer.
    – fsb
    Commented Jul 29, 2016 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .