My automatic backups for my Macs have recently started failing with the following message (same error if I attempt to "Backup Now"):

Time Machine couldn't complete the backup to "DeviceName".
The backup disk is not available.

Every other attempt or so I also get a warning that it was a while ago that a backup succeeded. If I open Time Machine Preferences there is a red icon with an exclamation mark next to the backup disk which if clicked produces the following message:

Time Machine Error
The backup disk is not available.
Latest successful backup: <date>

I just tried to re-select the backup disk from Time Machine Preferences > Select Disk, which worked without problem, but now Time Machine seems to have forgotten all my previous backups (I can still find the backups on disk using Finder, but Time Machine claims that I have no previous backups).


  1. Now that I have reselected the backup disk, how do I get Time Machine to find the existing backups?
  2. Is there another way to get Time Machine to find the backup disk?

Setup: One Macbook Air, one Macbook Pro, one Netgear ReadyNAS Duo claiming to be a TimeCapsule. Both Macs use Mountain Lion.

  • What do you see when you access the NAS in finder? Do you see any folders?
    – Pekka
    Commented Oct 28, 2012 at 20:01
  • 1
    When mounting the NAS with the Time Machine credentials (by executing "Enter Time Machine") I could see all the backup folders for my machine (e.g. Backups.backupdb/Machine/Date), so it seemed as if credentials and configuration were correctly set.
    – erikxiv
    Commented Nov 1, 2012 at 23:16

3 Answers 3


I've now gotten Time Machine to see the older backups. Not sure if the first step is necessary as I noted that Time Machine Preferences took a while to update the "Latest backup" date, so it might have been enough to just perform a backup.

Step 1 - Verify the backups

  • Following a guide on a similar topic I deleted the com.apple.TimeMachine.MachineID.plist file (on my ReadyNAS this was located under /c/.timemachine/MachineName.sparsebundle/)
  • Have Time Machine verify your backups by having the alt-key pressed while clicking the Time Machine icon and choosing Verify Backups

At this stage Time Machine Preferences still states that I have no backups, but by choosing Enter Time Machine I can see the earlier backups.

Step 2 - Take a new backup

After this was done, Time Machine Preferences update both the Latest Backup date and Oldest Backup date to correct values.


I have a Time Capsule, and had a lot of trouble with backups failing with an error "Backup Disk not Available". Rebooting the Time Capsule fixed the problem but only for one time backup. I resolved the problem by opening the AirPort Utility, selecting Disks, and changing the option "Secure Shared Disks" from "With a device password" (this was the Time Capsule password) to "With a disk password" (a new password for the disk). Now it works fine and I am able to backup from two separate macs without issues.


Just had this problem and this worked: 1.Shut down Mac 2.unplug from electric the Time machine and Modem 3.Reboot modem - wait till complete 4.replug Time machine into electric - once you see the green light on the machine turn on your Mac. 5.Go to Time Machine and choose "Back up now" - should work

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .