I've got a strange problem with the SD card reader on Bootcamp. It reads some of my cards fine (one 8GB, one 4GB, and one 512MB), but it has problems with some others (64GB SDXC, an identical 8GB). When I try to read a file from the 64GB one, it usually freezes the application trying to open it, or sometimes it says an unknown error occurred. If I try to write to the card, it takes forever and is almost always corrupted when reading on another computer.

This problem seems to be with the built-in card reader drivers for Bootcamp, because it works perfectly on the Mac side and also works perfectly when I use an external card reader in Bootcamp.

I've got Parallels installed to use Bootcamp without restarting, I don't know if this is affecting it... I've tried uninstalling the "Broadcom SD Host Controller" and removing drivers and reinstalling, but nothing's changed...

Just to be clear, I'm in Windows directly, not through Parallels...

Things I've tried

  • Reinstalling "Broadcom SD Host Controller"
  • Reinstalling WindowsSupport drivers
  • Reinstalling Windows entirely
  • Formatting cards as exFAT in Mac

2 Answers 2


Try to isolate the problem as much as possible first.

Boot straight into windows (not thru parallels) and test the cards to see if they work. If they don't, the problem is with the driver inside w7. If they do work then the problem might be in the way parallels shares the hardware access with W7.

When using parallels to access the hardware you are not using the actual drivers as you don't have access to the actual hardware, just a parallel's emulation of the hardware and an interface to it in osx.

If the problem persists in W7 reinstall the windows support files as it should work (mine works with SDXC perfectly), but this WONT fix the paralles problem.

As I said the parallels problem is completely separated and much harder as you can't switch drivers. But try this: http://lifehacker.com/368819/access-usb-drives-in-parallels-and-your-mac-simultaneously

ie: add /Volumes as a shared folder (its where OSX mounts HD/USB/SD/DVD drives)

  • Hi, sorry I forgot to say that this is happening when booting directly into Bootcamp, I've never tried the cards through Parallels...
    – jjv360
    Commented Oct 29, 2012 at 9:30
  • Sorry, didnt see your comment until today. Did you try reinstalling the Windows Support files (ie bootcamp drivers) ?
    – Rostol
    Commented Nov 12, 2012 at 23:13
  • Hi, I tried that, I even reinstalled Windows completely, but it's still doing it...
    – jjv360
    Commented Nov 13, 2012 at 8:09
  • I bought a 16GB card the other day and it works perfectly in Windows, and I've got 2 identical 8GBs and only one of them works in Windows. They're all formatted with exFAT. They all work on the Mac side and in other Windows laptops, so I really cannot understand what could be causing this...
    – jjv360
    Commented Nov 13, 2012 at 9:29

Did you try all the sdcards after a full power cycle on/off/on? On many Macbook models, it's a known bug that it's not accessable after Windows goes to sleep without fully powering off. https://discussions.apple.com/thread/8038937

I recommend you fully reboot the laptop before trying to read the sdcard.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .