3

I have installed an application that is associated with a particular file type. When I double click a file of that type in Finder, the application starts, but does not open the file that was clicked. If, within the application, I use “File » Open…” to open the same file, it opens it just fine. At first I thought this was the fault of the application (Simple Comic); however, I have installed an alternative application (Sequential 2) and the behaviour is the same: when double-clicking the file from Finder, the application starts up, but fails to load the file. However files are being opened just fine if I use the “File » Open” dialog.

Both applications are distributed as app bundles (i.e. no installer) and I have placed them into the /Applications folder manually.

I suspect this is a generic OS X issue, that I am not aware of, and is not related to the particular application.

  • What happens with .txt or .rtf files do they open in TextEdit correctly? If so then I think you have unluckily found two bad programs – user151019 Oct 28 '12 at 12:09
  • Thanks for the comment Terry. All other applications seem to work fine, however I have searched a bit more on the internet and found others having the very same problem sometimes with Adobe Acrobat or even Photoshop. So I think this is not a problem of bad application (many people use Simple Comic without any problems), but of the particular configuration (settings) on my OSX. – Denis Oct 28 '12 at 12:16
  • Have you considered useing RCDefaultApp by rubicode to manually check if that application is taking control of the extensions and types . – neeks Oct 31 '12 at 8:52
  • I would recommend creating a test user account on your Mac and attempting the same task in that account. I have seen apps coded using non-native Apple tools that have trouble opening files passed to it by the file system, so it is certainly possible it is these apps. – bispymusic Mar 13 '13 at 2:17
  • I had a similar issue last year, and it affected at least TextMate and Skim. I think it went away after I did an upgrade install from the recovery partition, but just upgrading to 10.9 might also fix it. – Lri Apr 13 '13 at 12:03

Browse other questions tagged .