102

I would like to mount an SMB network share from the command line (terminal); how would I go about that?

I am using Mac OS X 10.6.4.

  • I posted an answer here for a similar question, with an overview of the different methods to do that and their advantages and disadvantages. – mivk Aug 10 at 17:45
90

You could easily achieve this using mount_smbfs (which is, actually, a wrapper for mount -t smbfs) :

mount_smbfs //user@SERVER/folder ./mntpoint

Optionally, add the workgroup :

mount_smbfs -W workgroup //user@SERVER/folder ./mntpoint

You could, of course, change the ./mntpoint (for something like /Volumes/smb).

After doing this, simply go to ./mntpoint to browse your data.

To unmount, using the following command :

umount ./mntpoint
| improve this answer | |
  • 2
    I get : `mount_smbfs: mount error: path: Input/output error', while it mounts find via Finder->Connect to Server? – Ian Vaughan Mar 2 '12 at 16:53
  • How do I go about it if my username has a @ char in it? For example when i am using a microsoft account like xyz@microsoft.com ? I tried giving the username in single and double quotes but dint work.. – Yashvit Sep 13 '14 at 14:00
  • 4
    I get this error: mount_smbfs: could not find mount point /Volumes/Share: No such file or directory – Iulian Onofrei Feb 1 '16 at 8:35
  • 14
    Quote from man mount on OS X Yosemite: Note: You should always use the system mount command and never call mount_smbfs directly. – ssc Jun 30 '16 at 12:36
  • 4
    @Yashvit: Change the '@' to '%40' – WGroleau Aug 1 '16 at 4:11
90

Use the open(1) command and a URL:

open 'smb://username:password@server/share'

Pros: Creates the mount point in /Volumes for you.

Cons: Requires the Finder to be running.

| improve this answer | |
  • 4
    i prefer this version for quick connections in my local network, there all users are known, so this is a simpler command then using mount_smbfs - where i actually had problems concerning non existent paths - whereas if i would need to connect to some new server with special filesystem, or i would need to try another user or wanted different mount point - ok - but how often does this happen... so my thumb goes up for this simpler solution! Well Done! Ok i am a Terminal freak who still has Finder running, but that is like 90% of us, right? – hexerei software Sep 12 '15 at 14:00
  • Isn't Finder always opened, at least as a process? – Iulian Onofrei Feb 1 '16 at 8:40
  • 2
    @Iulian Onofrei: Not unless the user is logged in interactively. I've needed to use the direct mount command in cron jobs. Using the open command, these would fail if the interactive session was gone, e.g., after a power failure. – George Feb 9 '16 at 22:21
  • Also, note that open always exits as if it were successful if it passed the command along to Finder, even if the command later failed to connect to the network drive. – Jonathan Wren Jul 17 '16 at 2:15
29

You should take a look at mount’s help:

man mount

Upon closer inspection you’ll see that the filesystem’s type is:

mount -t smbfs //username:password@MACHINENAME/SHARENAME /SomeLocalFolderOfChoice

Password (and theoretically username) are optional.

The result of the above command will be no output (if all went ok), but a cd /SomeLocalFolderOfChoice, should produce the remote results. Please note that SomeLocalFolderofChoice must exist.

You can also use mount_smbfs to replace the mount -t smbfs.

| improve this answer | |
10

Using AppleScript is convenient because it stores your passwords in the Keychain. Bash function:

function mymount
{
    osascript <<EOF
mount volume "smb://user@fqdn1/volume1"
mount volume "smb://user@fqdn2/volume2"
EOF
}

Invoke ‘mymount’ from bash, enter passwords via the standard Keychain popup, and if all goes well the requested volumes will be mounted in /Volumes.

| improve this answer | |
  • 1
    That's perfect approach too. I don't like approved answer because it mounts as root user. In my opinion, these one-liners should be the best options: /usr/bin/osascript -e 'mount volume "smb://username:password@server/share"' or open /Volumes; open 'smb://username:password@server/share' – laimison May 8 '19 at 13:04
  • Additional improvement in case you want to use the current logged-in user name: replace "smb://user@fqdn1/volume1" with ""smb://$(id -un)@fqdn1/volume1". The bash command id -un resolves to the logged in user. – Rabarberski Sep 16 at 11:11
6

What worked for me to make them mount during boot:

==> /etc/auto_master <==
#
# Automounter master map
#
+auto_master        # Use directory service
/net            -hosts      -nobrowse,hidefromfinder,nosuid
/home           auto_home   -nobrowse,hidefromfinder
/Network/Servers    -fstab
/-          -static
/-          auto_smb          # add this line <**********

==> /etc/auto_smb <==         # Create this if it doesn't exist <****
/(not Volumes)/Public   -fstype=smbfs,soft smb://(user):(password)@192.168.140.5/data/Public
/(not Volumes)/ WGroleau -fstype=smbfs,soft smb://(user):(password)@192.168.140.5/data/Students/wes_groleau

For some reason, neither the short name nor the FQDN of the server worked, so I used 'ping (name) to get the IP. In other words, DNS would resolve the name, but mount_smbfs could not.

And I could not put the mount point in /Volumes, because boot up would delete it.

One quirk: After this worked fine for a few days, for two or three days, LibreOffice, Adobe Reader, and Finder could not find ONE of the two shares, but the shell and TextEdit had no problem. After two or three days of that, it mysteriously started working again.

If you do these edits and don't want to reboot, you can mount them with 'auto mount -vc'

Update: More quirks. (1) There are two WiFi systems here, and one of them has no access to the Windows servers. A couple of times a week, one or both of the routers goes down. If the "good one" goes down and the MacBook automatically connects to the other one, instead of telling me the drive is off-line, the SMB drivers say "Too many users." (2) A couple of times a week, I get "permission denied" when I try to access my Windows files. This typically lasts about a half-hour, during which I can go to a windows bar and log in and see files with the same ID and password.

| improve this answer | |
  • 1
    Since this has been upvoted twice this week, I should point out that it was written several versions of MacOS ago. – WGroleau Mar 30 '19 at 9:12
4

I would add that if you have a username of the form "workgroup\username", you should mount it like this :

mount -t smbfs "//WORKGROUP;username:password@MACHINENAME/SHARENAME" /SomeLocalFolderOfChoice

Source : adapting an example from here

| improve this answer | |
-1

Important to allow port 445 (TCP) to smb communication. If you don't access it, your firewall block it!

You can connect to samba use with the following commands in mac os: mount_smbfs or mount or use GUI see: open Finder click Go and select the Connect to Server menu item, type smb://yourdomain/sharedfoldername and press connect button.

| improve this answer | |
  • This is not an answer to the question. – Tetsujin Jan 27 at 10:42
  • yes, all right it is an answer to a problem when somebody cant access it, and it is important. The command line and the GUI method will not work without it. – István Döbrentei Jan 27 at 11:02
  • As helpful as this is, this should be a comment only. Although it is an important part of making sure SMB shares aren't blocked, it is not an answer to the original question! – IconDaemon Jan 27 at 13:16
  • I added it because the letters in the comment is small but my opinion is that it is an important setting. I would like to help others to see better. Sorry, I can't see well the small letters on the screen. "Thank you" for your downvote, I hope your eyes work better. – István Döbrentei Jan 27 at 20:26
-3

old post but what about mounting like this:

smb://no_username:password@MACHINENAME 

like the time machine drives?

| improve this answer | |
  • 2
    "from the command line (terminal)"... this is not a valid bash command. I assume you mean with Finder + ⌘K to connect to server which isn't what the OP asked. – mattmc3 May 15 '19 at 16:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .