2

I see this error when open jnlp file via javaws manually: java.lang.AssertionError: Threading violation: not AppKit thread

Is there anything I can do with it?

3

Once I reverted back to the Apple provided java packages, it fixed my problems.

The article for this download is:

Update: Note that for some people, the Java 7 update works with Lantronix Spiders. I can confirm that a colleague with the same model Macbook Pro has no problems using the latest Java 7 update. Another with a Macbook Air experiences the same issue, which is also resolved by rolling back.

  • 1
    Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. – Daniel Oct 30 '12 at 14:43
  • I've had the same problem with other KVM vendors... Seems they're very picky about the exact update of Java that you can have. – Brian Knoblauch Oct 30 '12 at 15:02
  • Remember to demand an update of your Latronix software from Latronix. – Thorbjørn Ravn Andersen Dec 15 '12 at 22:04
2

I found that on Lantronix Spider under Console settings, change "KVM Console Deployment" from "Web Start" to "Applet" and it worked again.

  • For me it started worked like magic, without any changes – Samat Dec 16 '12 at 18:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .