Recently, my iPhone 4's headphones won't stay seated in the jack. I'll push them in firmly, and then a few seconds later (without touching the phone, the headphones, or anything else), they'll pop back out – just enough to no longer make contact, pausing audio playback.

I first I thought it was the headphones themselves, but I've tried an older pair of iPod headphones (without the clicker), and the same thing happens, although not as badly.

If I fiddle enough with either pair, I can eventually get them to stay seated, but I can't tell what it is that makes them stay in on one particular attempt vs. another.

Is there anything I can do? The jack appears to be free of any dust/lint – should I try blowing it with some compressed air? I can't imagine that it's physically damaged on the inside, but I don't know why else the plug would pop out.

  • 5
    My bet is some accumulated dust/fabric. I've seen it clutter up before. You could try to clean it with a toothpick or something.
    – Gerry
    Oct 25, 2012 at 20:23
  • 1
    At the Apple Store, they usually have a bunch of paperclips around with little hooks bent in them to grab pocket lint from the slot. It can be hard to see. If you can't see the water-sensing dot, you have something in there. Oct 25, 2012 at 20:32
  • I have been trying to the above mentioned but there was some lint coming out but still nothing happens i have been trying so hard but my headfones just dont fit in What to do?
    – user46600
    Apr 3, 2013 at 7:45

1 Answer 1


@Gerry was right: there was dust or lint in the jack that was preventing the headphones from fully seating. I couldn't see it, but I used the end of a floss pick to clean it out and that fixed it. The headphones stay in so snugly now that I can actually lift the phone by pulling on them (not that I would do that normally; I just wanted to confirm it really worked!).

Amazing that just a little bit of dust could make all the difference. I'm just relieved that the phone itself wasn't damaged somehow since it's out of warranty.

  • It's quite easy for a little fuzz to interfere with the spring that is meant to hold the tip of the headphones in. A little more lint, and it physically prevents the jack from entering in far enough. Glad it was an easy fix.
    – bmike
    Oct 26, 2012 at 13:45
  • Apple used to include a little plastic cover for the dock connector with iPods, but they stopped doing that years ago (I actually saved mine from an old iPod and used it with my iPhone, but I ended up losing it). They should bring that back and make one for the headphone jack!
    – daGUY
    Oct 26, 2012 at 14:00
  • Holy crap. I've been dealing with this for months, and all it took was 15 seconds and a tooth pick. Thank you so much for your solution.
    – user38528
    Jan 13, 2013 at 17:00
  • @Matt: I was just as frustrated! I was so surprised that just a bit of dust in the jack could have an effect like that. I was almost sure it was physically damaged!
    – daGUY
    Jan 14, 2013 at 0:33
  • Omg you would not believe how much gunk I just pulled out of my headphone jack with a paperclip. Thank you! I thought the jack was defective!
    – devios1
    Oct 16, 2013 at 17:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .