So my Macbook Pro early 2011 13inch won't go to sleep.

I've tried both manually and closing the lid. Also tried in Safe Mode, which worked as normal. Seems to be a software problem.

When the lid is closed or it is manually put to sleep, the screen goes black (as it should) but power light stays lit continuously. Laptop doesn't respond again, and the only option is to turn it off then back on. Upon doing so, I get the 'unexpected restart' message before the computer boots up. When it has booted, I get prompted to send an error report to Apple.

syslog | grep -i "wake reason" does return wake reasons, such as the most recent one below (the last time I gave sleep a try):

Oct 24 15:11:05 Matthew-Ruddys-MacBook-Pro kernel[0] : Wake reason: EC.LidOpen (User)

I've tried disabling Login Items via the 'Users' System Preferences tab, but that didn't do the trick.

Upon booting up, I don't open any applications, so it doesn't appear to be caused by any applications I'm manually using.

Really stumped, and this is driving me crazy. Only started happening recently, but don't recall doing anything that triggered it. Lastly, tried resetting SMC to no avail.

Appreciate anyone that can help.

You must log in to answer this question.

Browse other questions tagged .