This happened after a wake from sleep. And rebooting doesn't solve the problem! Has anyone encountered this problem before?

Every item in the bar, for example Safari, has no previous and next arrows for the button, and Finder is missing sidebar icon.

  • Same issue here, 2 hours on phone with apple, no resolution. Going to rebuild machine from scratch.
    – user34281
    Commented Nov 7, 2012 at 18:28
  • @Doug I end up reinstalling Mountain Lion.
    – Shane Hsu
    Commented Nov 8, 2012 at 11:36
  • 1
    This happened again, and again, and again. All right, the RIGHT WAY to resolve this is to boot into safe mode and come back. To boot into safe mode, press shift after startup chime. To boot back, simply reboot.
    – Shane Hsu
    Commented Jan 30, 2013 at 4:58

4 Answers 4


I have the same problem with my Retina MBP (the 2.3 GHz model); after upgrading to the latest 10.8.2 (including the graphics update) and resuming from overnight sleep, all Apple applications (Safari, Finder, etc) are missing all icons from toolbar and menubar (see a screenshot).

This is second time I encounter the problem. At first time I did a clean reinstall of Mountain Lion (i.e. wiped the disk) and did not install the latest OS X updates. When I yesterday updated OS X (after a week), today the problem was back after resuming the machine from overnight sleep.

rm -rf'ing all files under /Library/Caches and ~/Library/Caches and rebooting did not help for me. I filed a bug report at https://bugreport.apple.com.


After reading this thread, I re-booted into safe-mode, then back to normal mode and the icons are now back. I disabled hibernation as a precaution, until Apple will fix the problem.

  • thanks, same here, clearing the cache did nothing, booting into save mode (by pressing shift while booting the machine) logging into my account and restarting, did the trick, though the thread machines this is temporary so we'll see how long it lasts ...
    – Samy Vilar
    Commented Apr 12, 2013 at 17:39
  • Work fine for me - safe mode and restart. Thanx!
    – user54100
    Commented Jul 28, 2013 at 20:52
  • Aug 13 and we are still experiencing the same bug on latest OS X 10.8.... BTW, this has nothign to do with being a Retina, I do have a MBP Early 2011.
    – sorin
    Commented Aug 13, 2013 at 17:39

FYI had a similar problem and worked through it with Apple Tech support.

Turned out in the end to be cache-related. Deleting all Cache items under:

  • ~/Library/Caches
  • /Library/Caches

did the trick. Sledgehammer approach (there's probably a specific apple cache file that is corrupt) but solved it for me.

Hope helps someone else.

  • It's not nearly the sledgehammer approach that reinstalling the OS is, though.
    – soxman
    Commented Nov 15, 2012 at 5:54
  • @Mark It happened to me again, today, and deleting them doesn't help. What steps did you take to fix it?
    – Shane Hsu
    Commented Nov 25, 2012 at 5:06

It has been 2 weeks since I post this question here, although I end up reinstalling Mountain Lion the same day I asked the question, I still hoped someone who resolved this problem less violently.

Well, I'm wrong.

Here's what I do, I restore Mountain Lion's InstallESD.dmg from AppStore's "Install Mountain Lion" App to an SD card, then boot my MacBook Pro off it.

You can do fine without it, just press option after bootup chime, and you got the option to boot to a restore mode, but, you do need an Internet connection for that. That's why I go with the SD card option since it download the whole Mountain Lion installer from Apple.


Creating a new user will help you to get back all the missing icons.

Source Apple Premium Reseller Sales Guy

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .