My iPhone, running iOS 6, used to autocorrect ill -> I'll for me and I liked that. It has, very recently, stopped doing this. I suppose it makes sense given than ill is actually a word, but it is a word I rarely use and certainly use far less frequently than I'll.

Is there any way to add a correction mapping back to the iOS 6 dictionary such that typing ill autocorrects to I'll for me?

  • I noticed this too a few weeks ago, on an iPhone which is still running iOS 5.
    – KatieK
    Oct 23, 2012 at 21:39

2 Answers 2


My workaround has been to add a keyboard shortcut that replaces the text ill with I'll any time I add it. Not perfect, but as a stop-gap it will do.

To add the shortcut go to Settings -> General -> Keyboard and scroll to the bottom of the page. You will see an Add New Shortcut... button. Press it.

enter image description here

In the Shortcut configuration page type I'll in to the Phrase entry box and ill in to the Shortcut entry box and press the Save button.

enter image description here

Now any time you type ill it will auto-correct to I'll.

  • Somehow my iPhone started autocorrecting "thr" to "Thr". This shortcut workaround solved that problem for me. Oct 23, 2012 at 20:33

It's an imperfect solution, but there's always the option of resetting the Keyboard Dictionary. This undoes all the learning your iPhone has done, so you're back to the fresh-out-of-the-box behaviour. Obviously this may be a set-back in some areas, but if you're getting strange behaviour, it may be the way to go.

To reset the learning, open Settings → General → Reset and tap Reset Keyboard Dictionary.

  • This is overkill.
    – duci9y
    Oct 24, 2012 at 8:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .