I'm following the instructions to create a bootable Ubuntu 12.10 USB stick on OS X found here. I can do step 3 and hdiutil appears to work fine, but when I go to mount the resulting ubuntu.img file I get the same "no mountable file systems" error that I get when I try and open the ubuntu.iso file. No correctly sized volumes show up in diskutil list either.

Any ideas?

Using the most recent ubuntu-12.10-desktop-amd64.iso on Mountain Lion 10.8.2.

I tried this with 12.04 LTS and got the same result.

  • 2
    The instructions don't say to mount the resulting file; rather, step 8 does a bit-copy from the image to the flash drive.
    – Jonathan
    Oct 22, 2012 at 16:41
  • 1
    You never have to mount any file. It’s all done without mounting anything.
    – duci9y
    Oct 23, 2012 at 4:58

2 Answers 2


From Ubuntu: This is due to a bug (of sorts) in the package used to create the Ubuntu ISOs

Since 11.10, Ubuntu ISOs have been "hybrid", meaning that the ISO can also be written bit-for-bit to a USB device to make it a working Live-USB, without having to use StartUp Disk Creator, UNetBootin, etc.

Note that this "hybrid" is different from the OS X/Disk Utility definition of "hybrid", which simply refers to an ISO readable on both Mac (HFS+) and Windows (ISO9660). Ubuntu's hybrid functionality is provided by the isohybrid script in the SysLinux bootloader. It works by encapsulating the standard ISO9660 CD filesystem within a partition, so that it will work unmodified if written to a USB/hard disk.

This patch/bug report discusses a problem in the way isohybrid sets GPT UUIDs, causing Disk Utility/OS X to fail to recognize the hybrid filesystem and consequently, failing to mount it. Hopefully it will be fixed at some point, making future Ubuntu hybrid ISOs compatible with Disk Utility.

Alternative to extract/explore Ubuntu ISOs on OS X: Keka

Keka is an open-source OS X frontend to the p7zip package, which is able to view and extract ISOs in addition to a myriad of other archive management features. While it won't let you "mount" the Ubuntu ISO on its own, it should let you view the ISO filesystem and extract what you need.

  • 1
    Do you have a link to a bug report about this? Apr 24, 2013 at 12:54
  • I'd love to have a way of extracting the contents of the ISO file and then creating a viable .img file so I can create the bootable USB device I want...
    – jester66
    Nov 23, 2013 at 10:32

This problem appears to be with Mountain Lion OS. I copied the downloaded ISO file over to a windows machine and burnt a CD from there which installed just fine.

You must log in to answer this question.