After upgrading to Mountain Lion, some pictures in my Aperture library are unreadable. Aperture says the format isn't supported.

I made some test and noticed that even the Finder, QuickLook or Preview can't read the picture either. However, Photoshop and Xee open it just fine.

It appears that system libraries can't read those pictures. With this in mind, I tried to take a faulty file to a Lion machine, and Aperture, Finder, QuickLook and Preview can open it without trouble. So, it's Mountain Lion related.

Not all my pictures are concerned, just some of them (but enough to care, and maybe many more : I have to open them to notice they can't be read) and I couldn't find common properties such as the camera, the import tools or something like that. Most of them seems to be a few years old.

Here's one of those faulty picture : http://6x7.be/DSCN5706.JPG

What's the cause? How can I fix it?

Notes :

  • I know I could recompress them, but I don't want to lose quality. In addition, finding them is very time consuming.
  • I performed my tests on multiple machine (for both Lion and Mountain Lion), I even tried on a clean install of Moutain Lion.

1 Answer 1


Well, the cause looks like it's this. Not sure how to fix it....

2012-10-22 8:50:27.959 AM quicklookd[63701]: ImageIO: JPEG Corrupt JPEG data: 400 extraneous bytes before marker 0xf3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .