I am copying using cp or mv on the command line a large amount (>500gb) of files each sized between 600MB and 2.6GB to an external drive (a Thermaltake BlacX Duet), but after a significant but inconsistent amount of transfer (e.g. 121gb) the following happens:

  • A message pops up in a dialog box that says "The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off." (There were no physical events that took place that would have resulted in a disconnection)
  • The copy fails for an item and all subsequent items, complaining with various errors including:
    • "device not configured"
    • "Invalid argument" (because the destination no longer exists)
    • "No such file or directory" (ibid)
  • The Terminal locks up
  • Executing 'Force Quit' on Terminal quits the Terminal, but it cannot be reopened
  • Finder locks up
  • No applications will start
  • Relaunching Finder causes the menu bar at the top and the dock to disappear
  • Rebooting does not succeed (i.e. one must hard-restart by holding the power button); variations on ejecting (before Finder locks) and unplugging the USB cable appear to have no effect on the inevitability of this result.

Note that roughly the same result occurs when attempting the same copy in Finder. In particular the dialog entitled "Copy" remains open, clicking the "Stop copy" "X" button causes an indefinite pause with "Stopping ..." showing. One can still access the Finder, and even read from the drive, but relaunching Finder causes it to display seemingly indefinitely "Application not responding" and in any case one cannot start new applications.

After rebooting, the destination has received most of the data. Disk utility reveals no issues with the destination drive.

I have Spotlight disabled for the external drive, if that makes any difference.

Obviously the expected behaviour from copying is not to have the computer hard-lock requiring a forced reboot.

For obvious reasons (Terminal being locked, applications won't start) it is hard to diagnose the problem.

Any insight would be greatly appreciated.


I have had some success by repartitioning the drive into two main partitions of about equal size (460GB) on the drive at the beginning and end with a medium sized partition in the middle (as it seems that this error is occurring at around the "middle" of the drive size). However, I am uneasy about this very speculative solution. But if it works, I can get on with life. :) In any case, insight into the nature of the underlying issue is most welcome.

  • Consumer operating systems are really bad with files of sizes that high. Most of the attempts you make to copy the files would result in failure. To avoid wasting time, energy and precious disk life, split your file into about 30 GB chunks and copy them one by one. Once copied, join them together.
    – duci9y
    Oct 21, 2012 at 15:29
  • @duci9y: Thanks for the msg. Sorry, I was unclear: the data is spread about among 600MB- 2.6 GB files. No single file is greater than 2.6 GB. Will clarify the question. Thanks Oct 21, 2012 at 15:47
  • Then you will have the highest success rate by chunking the data. Don’t know the underlying cause of the problem though, sorry.
    – duci9y
    Oct 21, 2012 at 17:23
  • Appears to be this issue Oct 21, 2012 at 22:52
  • and perhaps this one. Oct 22, 2012 at 12:15

3 Answers 3


The most common problem with external usb drives are the small power adapter with 2A. I have various WD Drives and all give up after a time with the same error "The disk was not ejected properly...". Without power the hd disconects (for a short time). I bought a bigger power adapter with 3 A and have no problems any more.


The external drives continue to exhibit erratic disconnections, though they no longer seem to be connected to items being copied to the drive or not. Sometimes an error message will pop up spontaneously stating "The disk was not ejected properly." For what it's worth I have tried other USB cables and all the USB ports on the back of the Mac. In any case, this may be a species of a known issue with the Thermaltake Duet and I will mark this as the answer (and leave it for anyone else who happens across a similar issue).

  • Did you by chance look at the console logs and see if there are any IO errors when the hardware was malfunctioning and timing out?
    – bmike
    Jan 23, 2013 at 13:35
  • @bmike: Sorry, I cannot recall. Jan 23, 2013 at 13:55
  • Thanks - in time, we may get some other reports as people experience this and can check the logs. Good answer.
    – bmike
    Jan 23, 2013 at 14:34

This has been a recent discovery for me as well. Same situation. I'm running the latest update of 10.8.2 and Finder seems to lock up after doing some file transfers to an external drive, then prompting me with the message "disk not ejected correctly". I restart my computer, same thing happens. I'm becoming very disappointed that my computer can't do even the most simplest task. I hope there is a fix for this soon.

  • The problem for me ultimately turned out to be hardware, I am afraid. Jan 23, 2013 at 12:49
  • This sounds to be a hardware issue rom my experience - see the accepted answer for perhaps more details and the possibility you can get a fix too by checking logs or checking other drives/that drive on another computer.
    – bmike
    Jan 23, 2013 at 13:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .